DE Title Page

Digital Electronics SV

2012

Project Lead The Way, Inc.

Clifton Park, NY

© All rights reserved


DE Course Description

Digital Electronics (DE) Course Description

Digital Electronics TM is the study of electronic circuits that are used to process and control digital signals. In contrast to analog electronics, where information is represented by a continuously varying voltage, digital signals are represented by two discreet voltages or logic levels. This distinction allows for greater signal speed and storage capabilities and has revolutionized the world electronics. Digital electronics is the foundation of all modern electronic devices such as cellular phones, MP3 players, laptop computers, digital cameras, high definition televisions, etc.

The major focus of the DE course is to expose students to the design process of combinational and sequential logic design, teamwork, communication methods, engineering standards, and technical documentation.

Utilizing the activity-project-problem-based (APPB) teaching and learning pedagogy, students will analyze, design and build digital electronic circuits. While implementing these designs students will continually hone their interpersonal skills, creative abilities and understanding of the design process.

Digital Electronics TM (DE) is a high school level course that is appropriate for 10th or 11th grade students interested in electronics. Other than their concurrent enrollment in college preparatory mathematics and science courses, this course assumes no previous knowledge.

Digital Electronics ™ is one of three foundation courses in the Project Lead The Way® high school pre-engineering program. The course applies and concurrently develops secondary level knowledge and skills in mathematics, science, and technology.

The course of study includes:

· Foundations of Digital Electronics

§ Scientific and Engineering Notations

§ Electronic Component Identification

§ Basic Soldering and PCB Construction

§ Electron Theory & Circuit Theory Laws

§ Circuit Simulation

§ Breadboard Prototyping

§ Component Datasheets & Troubleshooting

· Combinational Logic Analysis and Design

§ Binary, Octal and Hexadecimal Number Systems

§ Boolean Algebra and DeMorgan’s Theorems

§ AND-OR-INVERT, NAND Only, and NOR Only Logic Design.

§ Binary Adders and Two’s Complement Arithmetic

§ Combinational Logic Design with Field Programmable Gate Arrays

· Sequential Logic Analysis and Design

§ Flip-Flops, Latches and Their Applications.

§ Asynchronous Counter Design with Small and Medium Scale Integrated Circuits.

§ Synchronous Counter Design with Small and Medium Scale Integrated Circuits.

§ Sequential Logic Design with Field Programmable Gate Arrays

§ Introduction to State Machines.

· Introduction to Microcontrollers

§ Software Development for a Introductory Microcontroller

§ Real-World Interface: Introduction to Hardware Controls

§ Process Control with a Microcontroller


DE Student Resources

Student Resources

The Student Resources provide links to several useful documents in the Digital Electronics™ course.

Student Resources – contains documents students use throughout the course.

Engineering Abbreviations and Symbols | See Teacher
Citations APA Styles | htm | doc
DE Equations and Theorems | htm | doc
Example Design Process | htm | doc
Presentation Rationale | htm | doc
Sample Engineers Notebook Entry | htm | doc
Written Report Format | htm | doc
Isometric Paper Graph |  | pdf
Orthographic Paper Graph |  | pdf
Key Terms Glossary | htm | doc


Unit 1- Fundamentals of Analog & Digital Electronics

Unit 1 – Fundamentals of Analog and Digital Electronics

Concepts

1. Safety is an important concept that must be considered for the safety of the individual, class, and overall environment of the classroom/laboratory.

2. Electricity, even at the nominal levels used in this curriculum, can cause bodily harm or even death.

3. Engineers and technicians use scientific notation, engineering notation, and Systems International (SI) notation to conveniently write very large or very small numbers frequently encountered when working with electronics.

4. Manufacturers of resistors and capacitors use an accepted industry standard to label the nominal value of resistors and capacitors.

5. Soldering is the process of joining two metal surfaces together to form an electrical connection. Soldering is used extensively in the assembly of electronic components.

6. The ability to properly solder electronic components and recognition of improper solder connections is an important skill for engineers and technicians.

7. Analog and digital signals have different waveforms with distinctive characteristics.

8. Digital signals have two well-defined voltage levels, one for a logic high and one for a logic low.

9. Analog signals have an infinite number of voltage levels that vary continuously over the voltage range for that particular system.

10. The atomic structure of a material determines whether it is a conductor, an insulator, or a semiconductor.

11. An understanding of the basics of electricity requires the understanding of three fundamental concepts of voltage, current, and resistance

12. Engineers and technicians use Circuit Design Software as a tool to verify functionality of their analog and digital designs.

13. The manufacturer datasheet contains a logic gate’s general description, connection diagram, and function table.

14. Integrated circuits are categorized by their underlying circuitry, scale of integration, and packaging style.

15. Transistor-Transistor Logic (TTL) gates are available in a series of sub-families, each having their own advantages and disadvantages related to speed and power.

16. Logic gates are depicted by their schematic symbol, logic expression, and truth table.

17. The output of combinational logic is a function solely of the present input values.

18. The output of sequential logic is a function of the current input values as well as previous output values.

19. Combinational logic designs implemented with AND gates, OR gates, and INVERTER gates are referred to as AOI designs.

20. The flip-flop is the fundamental building block of sequential logic.

21. The ability to troubleshoot electronic circuits is an important skill for engineers and technicians.

Essential Questions

Lesson 1.1: Foundations and the Board Game Counter

1. Why is safety of the utmost importance when working with electricity or electronics?

2. What level of electrical current is safe for the human body? What level of electrical current can kill a human? What are the factors that affect the level of harm (i.e., slight pain to death) that electrical current can cause the human body?

3. Why is it important to express very large and very small numbers in proper scientific, engineering and Systems International (SI) notation? What is the process for doing so?

4. What is the resistor color code, and how is it used to identify and select resistors?

5. What is the labeling nomenclature for capacitors, and how is it used to identify and select capacitors?

6. What is the process for properly soldering and de-soldering electronic components from a printed circuit board?

7. What are the characteristics of a good solder connection? What are the most common soldering mistakes and how are they identified?

Lesson 1.2: Introduction to Analog

1. What are the characteristics of analog and digital signals?

2. What are the voltage levels associated with digital signals?

3. What is the voltage range of an analog signal?

4. What determines whether a material is a conductor, an insulator, or a semiconductor?

5. An understanding of basic electricity requires the understanding of what three fundamental concepts?

6. What is the relationship between voltage, current, and resistance in an electrical circuit?

7. What is true about the sum of all voltages around a closed path in an electrical circuit?

8. What is a breadboard, and what is it used for?

9. What function does a Circuit Design Software serve when designing analog and digital circuit?

Lesson 1.3: Introduction to Digital Electronics

1. What information is contained in a manufacturer datasheet for logic gates?

2. What are the three characteristics that categorize integrated circuits?

3. What are the available Transistor-Transistor Logic sub-families?

4. What are the three ways to depict any logic gate?

5. What are the outputs of combinational logic a function of?

6. What is AOI logic?

7. What are the outputs of sequential logic a function of?

8. What is the fundamental building block of sequential logic?

9. What are the steps for troubleshooting digital electronics circuits?

Unit Evaluation

The Essential Questions and Conclusion questions at the end of each activity may be used along with the Assessment suggestions provided in each lesson to develop summative assessment tools, such as tests or end of unit projects.


Lesson 1.1 Foundations & The Board Game Counter

Lesson 1.1 Foundations and the Board Game Counter

Concepts

1. Safety is an important concept that must be considered for the safety of the individual, class, and overall environment of the classroom/laboratory.

2. Electricity, even at the nominal levels used in this curriculum, can cause bodily harm or even death.

3. Engineers and technicians use scientific notation, engineering notation, and Systems International (SI) notation to conveniently write very large or very small numbers frequently encountered when working with electronics.

4. Manufacturers of resistors and capacitors use an accepted industry standard to label the nominal value of resistors and capacitors.

5. Soldering is the process of joining two metal surfaces together to form an electrical connection. Soldering is used extensively in the assembly of electronic components.

6. The ability to properly solder electronic components and recognition of improper solder connections is an important skill for engineers and technicians.

Performance Objectives

It is expected that students will:

· Know and practice proper safety while working with electronics.

· Be able to express numbers in scientific notation, engineering notation, and System International (SI) notation.

· Identify many of the common components used in electronics.

· Be able to determine a resistor’s nominal value by reading its color code.

· Be able to determine a resistor’s actual value by reading its resistance with a Digital Multimeter (DMM).

· Be able to determine a capacitor’s nominal value by reading its labeled nomenclature.

· Be able to properly tin the tip of a soldering iron.

· Use proper soldering/de-soldering techniques to solder and de-solder components on a printed circuit boards.

Essential Questions

1. Why is safety of the utmost importance when working with electricity or electronics?

2. What level of electrical current is safe for the human body? What level of electrical current can kill a human? What are the factors that affect the level of harm (i.e., slight pain to death) that electrical current can cause the human body?

3. Why is it important to express very large and very small numbers in proper scientific, engineering and Systems International (SI) notation? What is the process for doing so?

4. What is the resistor color code, and how is it used to identify and select resistors?

5. What is the labeling nomenclature for capacitors, and how is it used to identify and select capacitors?

6. What is the process for properly soldering and de-soldering electronic components from a printed circuit board?

7. What are the characteristics of a good solder connection? What are the most common soldering mistakes and how are they identified?

Key Terms

Capacitor | An electrical device used to store electrical charge.
Cold Solder Joint | A solder connection that exhibits poor wetting and is characterized by a grayish, porous appearance due to excessive impurities in the solder, inadequate cleaning prior to soldering, and/or the insufficient application of heat during the soldering process.
Digital Multimeter | Electronic test equipment that can perform multiple tasks. Typically one capable of measuring voltage, current, and resistance. More sophisticated modern digital multimeters also measure capacitance, inductance, current gain of transistors, and/or anything else that can be measured electronically.
Diode | A two terminal device that conducts in only one direction.
Dual In-Line Package (DIP) | A very common IC package with two parallel rows of pins intended to be inserted into a socket of through holes drilled in a printed circuit board.
Engineering Notation | A floating point system in which numbers are expressed as products consisting of a number greater than one multiplied by an appropriate power of ten that is some multiple of three.
Fuse | A protective device in the current path that melts or breaks when current exceeds a predetermined maximum value.
LED | Light-emitting diode. An electronic device that conducts current in one direction only and illuminates when it is conducting.
Plastic Leaded Chip Carrier (PLCC) | A square IC package with leads on all four sides designed for surface mounting on a circuit board.
Printed Circuit Board | Insulating board containing conductive tracks for circuit connections.
Resistor | Component made of material that opposes flow of current and therefore has some value of resistance.
Resistor Color Code | Coding system of colored stripes on a resistor to indicate the resistor's value and tolerance.
Scientific Notation | Numbers entered as a number from one to ten multiplied by a power of ten.
SI Notation | Abbreviation of System International, a system of practical units based on the meter, kilogram, second, ampere, Kelvin, mole, and candela.
Seven-Segment Display | An array of seven independently controlled light-emitting diodes (LED) or liquid crystal display (LCD) elements, shaped like a figure-8, which can be used to display decimal digits and other characters by turning on the appropriate elements.
Small Outline IC (SOIC) | An IC package similar to a DIP, but smaller, which is designed for automatic placement and soldering on the surface of a circuit board.
Solder | Metallic alloy of tin and lead that is used to join two metal surfaces.
Solder Bridge | The unwanted formation of a conductive path of solder between conductors.
Soldering | Process of joining two metallic surfaces to make an electrical contact by melting solder (usually tin and lead) across them.
Soldering Iron | Tool with an internal heating element used to heat surfaces being soldered to the point where the solder becomes molten.
Tinning | The process of applying a thin coat of solder to materials prior to their being soldered; for example, application of a light coat of solder to the filaments of a conductor to hold the filaments in place prior to soldering the conductor.
Transistor | Term derived from "transfer resistor." Semiconductor device that can be used as an amplifier or as an electronic switch.

Instructional Resources

Presentations

General Safety

Scientific & Engineering Notation

Component Identification

Soldering & De-Soldering

Board Game Counter

Word Documents

Lesson 1.1 Key Term Crossword

Activity 1.1.1 General Safety Quiz

Activity 1.1.2 Scientific & Engineering Notation

Activity 1.1.3 Component Identification

Activity 1.1.4 Solder & De-Soldering Practice

Project 1.1.5 Board Game Counter

Reference Sources

Dueck, R. & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

Schultz, M. E. (2007). Grob’s basic electronics: Fundamentals of DC and AC circuits. New York, NY: McGraw Hill.

Pecht, M. (1993). Soldering processes and equipment. New York, NY: John Wiley & Sons.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 1.2 Introduction to Analog

Concepts

1. Analog and digital signals have different waveforms with distinctive characteristics.

2. Digital signals have two well-defined voltage levels, one for a logic high and one for a logic low.

3. Analog signals have an infinite number of voltage levels that vary continuously over the voltage range for that particular system.

4. The atomic structure of a material determines whether it is a conductor, an insulator, or a semiconductor.

5. An understanding of the basics of electricity requires the understanding of three fundamental concepts of voltage, current, and resistance

6. Engineers and technicians use Circuit Design Software as a tool to verify functionality of their analog and digital designs.

Performance Objectives

It is expected that students will:

· Be able to identify the parts of an atom and determine if an element would make a good conductor, insulator, or semiconductor.

· Use Ohm’s Law, Kirchhoff’s Voltage Law, and Kirchhoff’s Current Law to solve for simple series and parallel circuit.

· Be able to use a Circuit Design Software to analyze simple analog circuits.

· Be able to use a breadboard and digital multimeter to analyze simple analog circuits.

· Be able to determine the amplitude, period, frequency, and duty cycle analog and digital signals.

· Be able to analyze and design simple digital oscillators using the 555 Timer chip.

· Utilize the Circuit Design Software (CDS) to simulate and test a complete analog design.

Essential Questions

1. What are the characteristics of analog and digital signals?

2. What are the voltage levels associated with digital signals?

3. What is the voltage range of an analog signal?

4. What determines whether a material is a conductor, an insulator, or a semiconductor?

5. An understanding of basic electricity requires the understanding of what three fundamental concepts?

6. What is the relationship between voltage, current, and resistance in an electrical circuit?

7. What is true about the sum of all voltages around a closed path in an electrical circuit?

8. What is a breadboard, and what is it used for?

9. What function does a Circuit Design Software serve when designing analog and digital circuit?

Key Terms

Analog | A way of representing some physical quantity, such as temperature or velocity, by a proportional continuous voltage or current. An analog voltage or current can have any value within a defined range.
Amplitude | The instantaneous voltage of a waveform. Often used to mean maximum amplitude, or peak voltage, or a pulse.
Atom | The smallest particle of an element that still has the same characteristics as the element.
Breadboard | A circuit board for wiring temporary circuits, usually used for prototypes or laboratory work.
Conductor | Any material that allows the free movement of electric changes, such as electrons, to provide an electric current.
Conventional Current | The direction of current flow associated with positive charge in motion. The current flow direction is from a positive to negative potential, which is in the opposite direction of electron flow.
Clock | Digital signal in the form of a rectangular pulse train or a square wave.
Current | A movement of electrical charges around a closed path or circuit.
Digital | A way of representing a physical quantity by a series of binary numbers. A digital representation can have only specific discrete values.
Digital Waveform | A series of logic 1s and 0s plotted as a function of time.
Digital Multi-Meter(DMM) | A piece of test equipment used to measure voltage, current, and resistance in an electronic circuit.
Duty Cycle (DC) | Fraction of the total period that a digital waveform is in the HIGH state. DC = th/T (often expressed as a percentage: %DC = th/Tx100%).
Electron | Basic particle of negative charge in orbit; around the nucleus in an atom.
Electron Flow | Current of negative charges in motion. Direction is from the negative terminal of the voltage source, through the external, circuit, and returning to the positive side of the source. Opposite to the direction of conventional current.
Falling Edge | The part of a pulse where the logic level is in transition from a HIGH to a LOW.
Frequency | The number of cycles per unit time of a periodic waveform.
Hertz (Hz) | Unit of frequency. One hertz equals one cycle per second.
Insulator | A material that does not allow current to flow when voltage is applied because of its high resistance.
Kirchhoff’s Current Law (KCL) | The algebraic sum of all currents into and out of any branch point in a circuit must equal zero.
Kirchhoff’s Voltage Law (KVL) | The algebraic sum of all voltages around any closed path must equal zero.
Logic HIGH | The higher of two voltages in a digital system with two logic levels.
Logic LOW | The lower of two voltages in a digital system with two logic levels.
Nucleus | The massive, stable part of the atom that contains both protons and neutrons.
Ohms | Unit of resistance. Value of one ohm allow current of one ampere with potential difference of one volt.
Ohm’s Law | In electric circuits, I=V/R.
Oscilloscope | A piece of test equipment used to view and measure a variety of different waveforms.
Parallel Circuit | One that has two or more branches for separate current from one voltage source.
Period | The amount of time required for one complete cycle of a periodic event or waveform.
Proton | Particle with positive charge in the nucleus of an atom.
Simulation | Testing design function by specifying a set of inputs and observing the resultant outputs. Simulation is generally shown as a series of input and output waveforms.
Resistance | Opposition to current. Unit is the ohm.
Series Circuit | One that has only one path current.
Sine Wave | One in which amplitude varies in proportion to the sine function of an angle.
Square Wave | An almost instantaneous rise and decay of voltage or current in a periodic pattern with time and with a constant peak value.
555 Timer | TTL-compatible IC that can be wired to operate in several different modes, such as a one-shot and an astable multivibrator.

Instructional Resources

Presentations

Electron Theory

Circuit Theory Laws

Breadboard

Analog and Digital Signals

555 Timer

Board Game Counter - Analog

Word Documents

Lesson 1.2 Key Term Crossword

Activity 1.2.1 Electron Theory

Activity 1.2.2 Circuit Theory – Hand Calculations

Activity 1.2.3 Circuit Theory – Simulation

Activity 1.2.4 Circuit Theory – Breadboarding

Activity 1.2.5 Analog and Digital Signals

Activity 1.2.6 555 Timer

Project 1.2.7 Board Game Counter - Analog

Reference Sources

Dueck, R., & Reid, K. (2008). Introduction to digital electronics. Clifton Park , NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

Bignell, J., & Donovan, R. (2007). Digital Electronics. Clifton Park, NY: Thompson Delmar Learning.

Schultz, M. E. (2007). Grob’s basic electronics: Fundamentals of DC and AC circuits. New York, NY: McGraw Hill.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 1.3 Introduction to Digital

Lesson 1.3 Introduction to Digital Electronics

Concepts

1. The manufacturer datasheet contains a logic gate’s general description, connection diagram, and function table.

2. Integrated circuits are categorized by their underlying circuitry, scale of integration, and packaging style.

3. Transistor-Transistor Logic (TTL) gates are available in a series of sub-families, each having their own advantages and disadvantages related to speed and power.

4. Logic gates are depicted by their schematic symbol, logic expression, and truth table.

5. The input and output values of combinational and sequential logic function differently.

6. Combinational logic designs implemented with AND gates, OR gates, and INVERTER gates are referred to as AOI designs.

7. The flip-flop is the fundamental building block of sequential logic.

Performance Objectives

It is expected that students will:

· Be able to obtain and extract information from the manufacturer datasheets for components commonly used in digital electronics.

· Know how to identify commonly used electronic components given their part number or schematic symbol.

· Be able to identify various integrated circuit (IC) package styles.

· Know the fundamental differences between combinational and sequential logic.

· Identify and describe the function of AND, OR, & Inverter gates.

· Be able to use Circuit Design Software (CDS) to simulate and test a simple combinational logic circuit designed with AND, OR, & Inverter gates.

· Identify and describe the function of a D flip-flop.

· Be able to use Circuit Design Software (CDS) to simulate and test a simple sequential logic circuit design with D flip-flops.

· Utilize the Circuit Design Software (CDS) to simulate and test a complete design containing both combinational and sequential logic.

Essential Questions

1. What information is contained in a manufacturer datasheet for logic gates?

2. What are the three characteristics that categorize integrated circuits?

3. What are the available Transistor-Transistor Logic sub-families?

4. What are the three ways to depict any logic gate?

5. What are the outputs of combinational logic a function of?

6. What is AOI logic?

7. What are the outputs of sequential logic a function of?

8. What is the fundamental building block of sequential logic?

9. What are the steps for troubleshooting digital electronics circuits?

Key Terms

AND Gate | Digital circuit that implements the AND operation. The output of this circuit is HIGH only if all of its inputs are HIGH.
Boolean Expression | An algebraic expression made up of Boolean variables and operators, such as AND (-), OR (+), or NOT (-). Also referred to as Boolean function or a logic function.
Clocked D Flip-Flop | Type of flip-flop in which the D (data) input is the synchronous input.
Combinational Logic | Digital circuitry in which an output is derived from the combination of inputs, independent of the order in which they are applied.
Datasheet | A printed specification giving details of the pin configuration, electrical properties, and mechanical profile of an electronic device.
Digital Waveform | A series of logic 1s and 0s plotted as a function of time.
Dual In-Line Package (DIP) | One style of integrated circuit package which has two rows of lead.
Flip-Flop | A sequential circuit based on a latch whose output changes when its CLOCK input receives a pulse.
Frequency | The number of cycles per unit time of a periodic waveform.
Integrated Circuit (IC) | An electronic circuit having many components, such as transistors, diodes, resistors, and capacitors, in a single package.
Inverter | Also called a NOT gate or an inverting buffer. A logic gate that changes its input logic level to the opposite state.
Large Scale Integration (LSI) | An IC that contains circuitry equivalent to 100 gates or more.
Logic Diagram | A diagram, similar to a schematic, showing the connection of logic gates.
Logic Gate | An electronic circuit that performs a Boolean algebraic function.
Medium Scale Integration (MSI) | An IC that contains circuitry equivalent to more than 11 and less than 100 gates.
NOT Circuit | Also called an INVERTER gate or an inverting buffer. A logic gate that changes its input logic level to the opposite state.
OR Gate | Digital circuit that implements the OR operation. The output of this circuit is HIGH (logic level 1) if any or all of its inputs are HIGH.
Period | The amount of time required for one complete cycle of a periodic event or waveform.
Plastic Leaded Chip Carrier (PLCC) | Surface-mount integrated circuit package with leads that bend back under the package.
Propagation Delays (tPLH/tPHL) | Delay from the time a signal is applied to the time when the output makes its change.
Schematic Entry | A technique of entering CPLD design information by using a CAD (computer aided design) tool to draw a logic circuit as a schematic. The schematic can then be interpreted by design software to generate programming information for the CPLD.
Schottky TTL | TTL subfamily that uses the basic TTL standard circuit except that it uses a Schottky barrier code (SBD) connected between the base and the collector of each transistor for faster switching.
Sequential Logic | Digital circuitry in which the output state of the circuit depends not only on the states of the inputs, but also on the sequence in which they reached their present states.
Simulation | Testing design function by specifying a set of inputs and observing the resultant outputs. Simulation is generally shown as a series of input and output waveforms.
Small-Scale Integration (SSI) | An integrated circuit having 12 or fewer gates in one package.
Small Outline Integrated Circuit (SOIC) | Dual-inline style surface-mount IC package.
Transistor-Transistor (TTL) | A family of digital logic devices whose basic element is the bipolar junction transistor.
Truth Table | A list of all possible input values to a digital circuit, listed in ascending binary order, and the output response for each input combination.
555 Timer | TTL-compatible IC that can be wired to operate in several different modes, such as a one-shot and an astable multivibrator.

Instructional Resources

Presentations

Introduction to Logic & Datasheets

Combinational Logic – An Overview

Sequential Logic – An Overview

Board Game Counter – Digital

Troubleshooting

Word Documents

Lesson 1.3 Key Term Crossword

Activity 1.3.1 Combinational Logic

Activity 1.3.2 Sequential Logic

Project 1.3.3 Board Game Counter - Digital

Activity 1.3.4 Introduction to Logic & Datasheets

Reference Sources

Dueck, R., & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

Bignell, J., & Donovan, R. (2007). Digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Schultz, M. E. (2007). Grob’s basic electronics: Fundamentals of DC and AC circuits. New York, NY: McGraw Hill.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Unit 2 - Combinational Logic

Unit 2 – Combinational Logic

Concepts

1. An understanding of the binary number system and its relationship to the decimal number system is essential in the combinational logic design process.

2. The first step in designing a combinational logic circuit is to translate a set of design specifications into a truth table.

3. A truth table describes the behavior of a combinational logic design by listing all possible input combinations and the desired output for each.

4. Logic expressions can be derived from a given truth table; likewise, a truth table can be constructed from a given logic expression.

5. All logic expressions can be expressed in one of two forms: sum-of-products (SOP) or products of sum (POS).

6. All logic expressions, whether simplified or not, can be implemented using AND, OR, & Inverter Gates.

7. There is a formal design process for translating a set of design specifications into a functional combinational logic circuit.

8. Karnaugh Mapping is a graphical technique for simplifying logic expressions containing two, three, and four variables.

9. A don’t care condition is a situations where the design specifications “don’t care” what the output is for one or more input conditions. Don’t care conditions in K-Maps can lead to significantly simpler logic expressions and circuit implementations.

10. A NAND gate is considered a universal gate because it can be used to implement an AND gate, OR gate, and an inverter gate. Any combinational logic expression can be implemented using only NAND gates.

11. A NOR gate is considered a universal gate because it can be used to implement an AND gate, OR gate, and an inverter gate. Any combinational logic expression can be implemented using only NOR gates.

12. There is a formal design process for translating a set of design specifications into a functional combinational logic circuit implement with NAND or NOR gates.

13. Combinational logic designs implemented with NAND gates or NOR gates will typically required fewer Integrated Circuits (IC) than AOI equivalent implementations.

14. Seven-segment displays are used to display the digits 0-9 as well as some alpha characters.

15. The two varieties of seven-segment displays are common cathode and common anode.

16. Any combinational logic expression can be implemented with AOI, NAND, or NOR logic.

17. A formal design process exists for translating a set of design specifications into a functional combinational logic circuit.

18. An understanding of the hexadecimal and octal number systems and their relationship to the decimal number system is necessary for comprehension of digital electronics.

19. XOR and XNOR gates can be used to implement combinational logic circuits, but their primary intended purpose is for implementing binary adder circuits.

20. The addition of two binary numbers of any bit length can be accomplished by cascading one half-adder with one or more full adders.

21. Multiplexer/de-multiplexer pairs are most frequently used when a single connection must be shared between multiple inputs and multiple outputs.

22. Electronics displays that use multiple seven-segment display utilize de-multiplexers to significantly reduce the amount of power required to operate the display.

23. Two’s complement arithmetic is the most commonly used method for handling negative numbers in digital electronics.

24. Engineers and technicians use Circuit Design Software to enter and synthesize digital designs into programmable logic devices.

25. Programmable logic devices can be used to implement combinational logic circuits.

26. Circuits implemented with programmable logic devices require significantly less wiring than discrete logic, but they typically require a dedicated printed circuit board to hold the device.

27. Programmable logic devices can be used to implement any combinational logic circuits but are best suited for larger, more complex designs.

Essential Questions

Lesson 2.1 Introduction to AOI Logic

1. What are the processes for converting numbers between the binary and decimal number systems, and why is the understanding of these two numbers systems essential to your ability to design combinational logic circuits?

2. What is the relationship between a combinational logic design’s truth table, logic expression, and circuit implementation? Describe the process of obtaining any of the first two given the third.

3. When you simplify a logic expression using Boolean algebra, how do you know that you have the simplest solution and that the solution is correct?

4. In terms of circuit implementation, what is the advantage of representing all logic expression in either the SOP or POS form?

5. Defend the following statement: “All logic expression, regardless of complexity, can be implemented with AND, OR, & Inverter Gates.”

6. What are the steps in the design process of converting a set of design specifications into a functional combinational logic circuit?

Lesson 2.2: Introduction to NAND and NOR Logic

1. What is the process for using the K-Mapping technique to simplify a logic expression? What are the advantages of using this process over Boolean algebra?

2. What is a don’t care condition, and how can it be used in a K-Map to reduce the complexity of the combinational logic design?

3. What does the term universal gate mean? Why are NAND gates and NOR gates considered universal gates?

4. What is the advantage of implementing a combinational logic design with only NAND gates (or NOR gates)?

5. What are the steps in the design process for converting an AOI combinational logic design into a NAND only or NOR only design?

6. Typically, what is the advantage of NAND only design (or NOR only design) over an AOI design? Why is it important to it compare both the NAND only and NOR only designs?

Lesson 2.3: Date of Birth Design

1. What is the relationship between the resistor value used, the amount of current flowing, and the brightness of a segment of seven-segment display.

2. Why is it more difficult to design logic circuits with NAND logic or NOR logic than it is with straightforward AOI logic, in terms of circuit implementation.

3. Why does a logic expression require fewer ICs to implement if NAND logic or NOR logic is used than would be required if AOI logic were used.

4. What are the steps in the design process of converting a set of design specifications, containing multiple outputs, into a functional combinational logic circuit?

5. When compared to a design with a single output, is the process different for multiple outputs? Explain.

Lesson 2.4: Specific Comb Logic Circuits & Misc. Topics

1. What are the processes for converting numbers between the hexadecimal or octal and decimal number systems, and why is the understanding of these two numbers systems important to your comprehension of digital electronics?

2. In terms of circuit complexity, what is the advantage of implementing binary half and full adders with XOR gates over other logic gates?

3. Describe how the addition of two binary numbers of any bit length can be accomplished by cascading one half-adder with one or more full adders.

4. What is the basic operation of digital multiplexers and de-multiplexers?

5. Explain how digital de-multiplexers are used to significantly reduce the amount of power required to operate the electronics displays that use multiple seven-segment display.

6. What are the steps in the two’s complement process for adding or subtracting two binary numbers?

Lesson 2.5: Programmable Logic – Combinational

1. What is the design process for using a Circuit Design Software to enter and synthesize combinational logic into a programmable logic device?

2. Describe how programmable logic devices can be used to implement combinational logic circuits.

3. List the advantages and disadvantages of using a programmable logic device over discrete logic gates.

4. Why are programmable logic devices best suited for larger, more complex designs?

Unit Evaluation

The Essential Questions and Conclusion questions at the end of each activity may be used along with the Assessment suggestions provided in each lesson to develop summative assessment tools, such as tests or end of unit projects.


Lesson 2.1 Introduction to AOI Logic

Concepts

1. An understanding of the binary number system and its relationship to the decimal number system is essential in the combinational logic design process.

2. The first step in designing a combinational logic circuit is to translate a set of design specifications into a truth table.

3. A truth table describes the behavior of a combinational logic design by listing all possible input combinations and the desired output for each.

4. Logic expressions can be derived from a given truth table; likewise, a truth table can be constructed from a given logic expression.

5. All logic expressions can be expressed in one of two forms: sum-of-products (SOP) or products of sum (POS).

6. All logic expressions, whether simplified or not, can be implemented using AND, OR, & Inverter Gates.

7. There is a formal design process for translating a set of design specifications into a functional combinational logic circuit.

Performance Objectives

It is expected that students will:

· Convert numbers between the binary and decimal number systems.

· Translate design specifications into truth tables.

· Extract un-simplified logic expressions from truth tables.

· Construct truth tables from logic expressions.

· Use the rules and laws of Boolean algebra, including DeMorgan’s, to simplify logic expressions.

· Analyze AOI (AND/OR/Invert) combinational logic circuits to determine their equivalent logic expressions and truth tables.

· Design combinational logic circuits using AOI logic gates.

· Translate a set of design specifications into a functional AOI combinational logic circuit following a formal design process.

· Use Circuit Design Software (CDS) and a Digital Logic Board (DLB) to simulate and prototype AOI logic circuits.

Essential Questions

1. What are the processes for converting numbers between the binary and decimal number systems, and why is the understanding of these two numbers systems essential to your ability to design combinational logic circuits?

2. What is the relationship between a combinational logic design’s truth table, logic expression, and circuit implementation? Describe the process of obtaining any of the first two given the third.

3. When you simplify a logic expression using Boolean algebra, how do you know that you have the simplest solution and that the solution is correct?

4. In terms of circuit implementation, what is the advantage of representing all logic expression in either the SOP or POS form?

5. Defend the following statement: “All logic expression, regardless of complexity, can be implemented with AND, OR, & Inverter Gates.”

6. What are the steps in the design process of converting a set of design specifications into a functional combinational logic circuit?

Key Terms

Associative Property

A mathematical function is associative if its operands can be grouped in any order without affecting the result. For example, addition is associative ((a+b) + c = a + (b+c)), but subtraction is not ((a-b) –c ≠ a-(b-c)).

Binary Number System

A number system used extensively in digital systems, based on the number 2. It uses two digits to write any number.

Boolean Algebra

Algebraic process used as a tool in the design and analysis of digital systems. In Boolean algebra only two values are possible, 0 and 1.

Boolean Expression

An algebraic expression made up of Boolean variables and operators, such as AND (–), OR (+), or NOT (-). Also referred to as Boolean function or a logic function.

Boolean Theorems

Rules that can be applied to Boolean algebra to simplify logic expressions.

Boolean Variable

A variable having only two possible values, such as HIGH/LOW, 1/0, On/Off, or True/False.

Combinational Logic

Digital circuitry in which an output is derived from the combination of inputs, independent of the order in which they are applied.

Commutative Property

A mathematical operation is commutative if it can be applied to its operands in any order without affecting the result. For example, addition is commutative (a+b=b+a), but subtraction is not (a-b≠b-a).

Decimal System

Number system that uses 10 different digits or symbols to represent a quantity.

DeMorgan’s Theorems

1) Theorem stating that the complement of a sum (OR operation) equals the product (AND operation) of the complements, and

2) theorem stating that the complement of a product (AND operation) equals the sum (OR operation) of the complements.

Distributive Property

Full name: distributive property of multiplication over addition. The property that allows us to distribute (“multiply through”) an AND across several OR functions. For example, a(b+c)=ab+ac.

Least Significant Bit (LSB)

The rightmost bit of a binary num ber. This bit has the number’s smallest positional multiplier.

Logic Circuit

Any circuit that behaves according to a set of logic rules.

Logic Diagram

A diagram, similar to a schematic, showing the connection of logic gates.

Maxterm

A sum term in a Boolean expression where all possible variables appear once in true or complement form.

Minterm

A product term in a Boolean expression where all possible variables appear once in true or complement form.

Most Significant Bit (MSB)

The leftmost bit in a binary number. This bit has the number’s loargest positional multiplier.

Product-of-Sums (POS)

A type of Boolean expression where several sum terms are multiplied (ANDed) together.

Product Term

A term in a Boolean expression where one or more true or complement variables are ANDed.

Sum-of-Products (SOP)

A type of Boolean expression where several product terms are summed (ORed) together.

Sum Term

A term in a Boolean expression where one or more true or complement variables are ORed.

Truth Table

A list of all possible input values to a digital circuit, listed in ascending binary order, and the output response for each input combination.

Instructional Resources

Presentations

Combo Logic Design Process

Binary Number Systems & Conversion

Truth Tables & Logic Expressions

AOI Logic Analysis

AOI Logic Implementation

Boolean Algebra

DeMorgan’s Theorems

Word Documents

Lesson 2.1 Key Term Crossword

Project 2.1.1 Majority Vote

Activity 2.1.2 Binary Numbers & Conversion

Activity 2.1.3 Truth Tables & Logic Expressions

Activity 2.1.4 AOI Logic Analysis

Activity 2.1.5 AOI Logic Implementation

Activity 2.1.6 Boolean Algebra

Activity 2.1.6a Boolean Algebra and DeMorgan’s Theorems

Activity 2.1.7 DeMorgan’s Theorems

Reference Sources

Dueck, R. & Reid, K. (2008). Introduction to digital electronics. Clifton Park , NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, Thomas (2006). Digital Fundamentals. Upper Saddle River, NY Pearson Education

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 2.2 Nand & Nor Logic

Lesson 2.2 Intro to NAND & NOR Logic

Concepts

1. Karnaugh Mapping is a graphical technique for simplifying logic expressions containing two, three, and four variables.

2. A don’t care condition is a situations where the design specifications “don’t care” what the output is for one or more input conditions. Don’t care conditions in K-Maps can lead to significantly simpler logic expressions and circuit implementations.

3. A NAND gate is considered a universal gate because it can be used to implement an AND gate, OR gate, and an inverter gate. Any combinational logic expression can be implemented using only NAND gates.

4. A NOR gate is considered a universal gate because it can be used to implement an AND gate, OR gate, and an inverter gate. Any combinational logic expression can be implemented using only NOR gates.

5. There is a formal design process for translating a set of design specifications into a functional combinational logic circuit implement with NAND or NOR gates.

6. Combinational logic designs implemented with NAND gates or NOR gates will typically required fewer Integrated Circuits (IC) than AOI equivalent implementations.

Performance Objectives

It is expected that students will:

· Use the K-Mapping technique to simplify combinational logic problems containing two, three, and four variables.

· Be able to solve K-Maps that contain one or more don’t care conditions.

· Design combinational logic circuit using NAND and NOR logic gates.

· Translate a set of design specifications into a functional NAND or NOR combinational logic circuit following a formal design process.

· Be able to compare and contrast the quality of combinational logic designs implemented with AOI, NAND, and NOR logic gates.

· Use Circuit Design Software (CDS) and a Digital Logic Board (DLB) to simulate and prototype NAND and NOR logic circuits.

Essential Questions

1. What is the process for using the K-Mapping technique to simplify a logic expression? What are the advantages of using this process over Boolean algebra?

2. What is a don’t care condition, and how can it be used in a K-Map to reduce the complexity of the combinational logic design?

3. What does the term universal gate mean? Why are NAND gates and NOR gates considered universal gates?

4. What is the advantage of implementing a combinational logic design with only NAND gates (or NOR gates)?

5. What are the steps in the design process for converting an AOI combinational logic design into a NAND only or NOR only design?

6. Typically, what is the advantage of NAND only design (or NOR only design) over an AOI design? Why is it important to it compare both the NAND only and NOR only designs?

Key Terms

Adjacent Cell | Two cells in a K-map are adjacent if there is only one variable that is different between the coordinates of the two cells.
Cell | The smallest unit of Karnaugh map, corresponding to one line of a truth table. The input variables are the cell’s coordinates and the output variable is the cell’s contents.
Don’t Care Condition | Situation when a circuit’s output level for a given set of input conditions can be assigned as either a 1 or 0.
Karnaugh Map | A graphical tool for finding the maximum SOP or POS simplification of a Boolean expression. A Karnaugh map works by arranging the terms of an expression so that variable scans are cancelled by grouping minterms or maxterms.
NAND Gate | Logic circuit that operates like an AND gate followed by an INVERTER. The output of a NAND gate is LOW (logic level 0) only if all inputs are HIGH (logic level 1).
NOR Gate | Logic circuit that operates like an OR gate followed by an INVERTER. The output of a NOR gate is LOW (logic level 0) when any or all inputs are HIGH (logic level 1).

Instructional Resources

Presentations

Karnaugh Mapping

Universal Gate – NAND

Universal Gate - NOR

Comb Logic Design Process

Word Documents

Lesson 2.2 Key Term Crossword

Activity 2.2.1 K-Mapping

Activity 2.2.2 NAND Logic Design

Activity 2.2.3 NOR Logic Design

Activity 2.2.4 Logic Converter

Project 2.2.5 Fireplace Control Circuit

Reference Sources

Dueck, R. & Reid, K. (2008). Introduction to digital electronics. Clifton Park , NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 2.3 Date of Birth Design

Concepts

1. Seven-segment displays are used to display the digits 0-9 as well as some alpha characters.

2. The two varieties of seven-segment displays are common cathode and common anode.

3. Any combinational logic expression can be implemented with AOI, NAND, or NOR logic.

4. A formal design process exists for translating a set of design specifications into a functional combinational logic circuit.

Performance Objectives

It is expected that students will:

· Use a seven-segment display in a combinational logic design to display alpha/numeric values.

· Select the correct current limiting resistor and properly wire both common cathode and common anode seven-segment displays.

· Follow a formal design process to translate a set of design specifications for a design containing multiple outputs into a functional combinational logic circuit.

· Design AOI, NAND, & NOR solutions for a logic expression and select the solution that uses the least number of ICs to implement.

· Use Circuit Design Software (CDS) and Digital Logic Board (DLB) to simulate and prototype AOI, NAND, & NOR logic circuits.

Essential Questions

1. What is the relationship between the resistor value used, the amount of current flowing, and the brightness of a segment of seven-segment display.

2. Why is it more difficult to design logic circuits with NAND logic or NOR logic than it is with straightforward AOI logic, in terms of circuit implementation.

3. Why does a logic expression require fewer ICs to implement if NAND logic or NOR logic is used than would be required if AOI logic were used.

4. What are the steps in the design process of converting a set of design specifications, containing multiple outputs, into a functional combinational logic circuit?

5. When compared to a design with a single output, is the process different for multiple outputs? Explain.

Key Terms

Common Anode Display | A seven-segment LED display where the anodes of all the LEDs are connected to the circuit supply voltage. Each segment is illuminated by a logic LOW at its cathode.
Common Cathode Display | A seven-segment display in which the cathodes of all the LEDs are connected together and grounded. A logic HIGH illuminates a segment when applied to its anode.
Datasheet | A printed specification giving details of the pin configuration, electrical properties, and mechanical profile of an electronic device.
Design Specifications | A detailed description, especially one providing information needed to make, build, or produce something.
Seven-Segment Display | An array of seven independently controlled light-emitting diodes (LED) or liquid crystal display (LCD) elements, shaped like a figure 8, which can be used to display decimal digits and other characters by turning on the appropriate elements.

Instructional Resources

Presentations

Seven-Segment Displays

Date of Birth Design Problem

Word Documents

Lesson 2.3 Key Term Crossword

Activity 2.3.1 Seven-Segment Displays

Problem 2.3.2 Date of Birth

Reference Sources

Dueck, R. & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Floyd, Thomas (2006). Digital Fundamentals. Upper Saddle River, NY Pearson Education.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

MSN Encarta (March 2008). Dictionary. Retrieved March 19. 2008 from http://encarta.msn.com/dictionary_1861711433/specification.html


Lesson 2.4 Specific Combinational Logic Circuits & Miscellaneous Topics

Concepts

1. An understanding of the hexadecimal and octal number systems and their relationship to the decimal number system is necessary for comprehension of digital electronics.

2. XOR and XNOR gates can be used to implement combinational logic circuits, but their primary intended purpose is for implementing binary adder circuits.

3. The addition of two binary numbers of any bit length can be accomplished by cascading one half-adder with one or more full adders.

4. Multiplexer/de-multiplexer pairs are most frequently used when a single connection must be shared between multiple inputs and multiple outputs.

5. Electronics displays that use multiple seven-segment display utilize de-multiplexers to significantly reduce the amount of power required to operate the display.

6. Two’s complement arithmetic is the most commonly used method for handling negative numbers in digital electronics.

Performance Objectives

It is expected that students will:

· Convert numbers between the hexadecimal or octal number systems and the decimal number system.

· Use XOR and XNOR gates to design binary half-adders and full-adders.

· Use SSI and MSI gates to design and implement binary adders.

· Design electronics displays using seven-segment displays that utilize de-multiplexers.

· Use the two’s complement process to add and subtract binary numbers.

· Use Circuit Design Software (CDS) and a Digital Logic Board (DLB) to simulate and prototype specific combinational logic circuits.

Essential Questions

1. What are the processes for converting numbers between the hexadecimal or octal and decimal number systems, and why is the understanding of these two numbers systems important to your comprehension of digital electronics?

2. In terms of circuit complexity, what is the advantage of implementing binary half and full adders with XOR gates over other logic gates?

3. Describe how the addition of two binary numbers of any bit length can be accomplished by cascading one half-adder with one or more full adders.

4. What is the basic operation of digital multiplexers and de-multiplexers?

5. Explain how digital de-multiplexers are used to significantly reduce the amount of power required to operate the electronics displays that use multiple seven-segment display.

6. What are the steps in the two’s complement process for adding or subtracting two binary numbers?

Key Terms

De-multiplexer | A circuit that uses a binary decoder to direct a digital signal from a single source to one of several destinations.
Encoder | A digital circuit that produces an output code depending on which of its inputs is activated.
Exclusive-NOR (XNOR) Circuit | Two-input logic circuit that produces a high output only when the inputs are equal.
Exclusive-OR (XOR) Circuit | Two-input logic circuit that produces a high output only when the inputs are different.
Full Adder | Logic circuit with three inputs and two outputs. The inputs are a carry bit (CIN) from a previous stage, a bit from the augend, and a bit from the addend, respectively. The outputs are the sum bit and the carry-out bit (COUT) produced by the addition of the bit from the addend with the bit from the augend and CIN.
Half Adder | Logic circuit with two inputs and two outputs. The inputs are a bit from the augend and a bit from the addend. The outputs are the sum bit produced by the addition of the bit from the addend with the bit from the augend and the resulting carry (COUT) bit, which will be added to the next stage.
Hexadecimal Number System | Base-16 number system. Hexadecimal numbers are written with sixteen digits, 0-9 and A-F, with power-of-16 positional multipliers.
Multiplexer | A circuit that directs one of several digital signals to a single output, depending on the states of several select inputs.
Octal Number System | A number system that has a base of 8; digits from 0 to 7 are used to express an octal number.
Seven-Segment Display | An array of seven independently controlled light-emitting diodes (LED) or liquid crystal display (LCD) elements, shaped like a figure-8, which can be used to display decimal digits and other characters by turning on the appropriate elements.
Signed Binary Number | A binary number of fixed length whose sign is represented by one bit, usually the most significant bit, and whose magnitude is represented by the remaining bits.
Sign Bit | A binary bit that is added to the leftmost position of a binary number to indicate whether that number represents a positive or a negative quantity.
1’s Complement | A form of signed binary notation in which negative numbers are created by complementing all bits of a number, including the sign bit.
2’s Complement | A form of signed binary notation in which negative numbers are created by adding 1 to the 1’s complement form of the number.

Instructional Resources

Presentations

Octal & Hexadecimal Number Systems

XOR, XNOR, & Binary Adders

Two’s Complement Arithmetic

Multiplexers & De-multiplexers

Word Documents

Lesson 2.4 Key Term Crossword

Activity 2.4.1 Octal & Hexadecimal Number Systems

Activity 2.4.2 XOR, XNOR, & Binary Adders

Activity 2.4.3 Two’s Complement Arithmetic

Activity 2.4.4 Multiplexers & De-multiplexers

Reference Sources

Dueck, R., & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

International Technology Education Association (ITEA). (2002). Standards for technological literacy.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 2.5 Programmable Logic: Combinational

Concepts

1. Engineers and technicians use Circuit Design Software to enter and synthesize digital designs into programmable logic devices.

2. Programmable logic devices can be used to implement combinational logic circuits.

3. Circuits implemented with programmable logic devices require significantly less wiring than discrete logic, but they typically require a dedicated printed circuit board to hold the device.

4. Programmable logic devices can be used to implement any combinational logic circuits but are best suited for larger, more complex designs.

Performance Objectives

It is expected that students will:

· Design combinational logic circuits using a programmable logic device.

· Be able to cite the advantages and disadvantages of programmable logic devices over discrete logic gates.

· Use Circuit Design Software (CDS) and a Digital Logic Board (DLB) to simulate and prototype combinational logic designs implemented with programmable logic.

Essential Questions

1. What is the design process for using a Circuit Design Software to enter and synthesize combinational logic into a programmable logic device?

2. Describe how programmable logic devices can be used to implement combinational logic circuits.

3. List the advantages and disadvantages of using a programmable logic device over discrete logic gates.

4. Why are programmable logic devices best suited for larger, more complex designs?

Key Terms

Complex PLD (CPLD) | A digital device consisting of several programmable sections with internal interconnections between the sections.
Compiler | The process used by CPLD design software to interpret design information (such as a schematic or text file) and create required programming information for a CPLD.
Design Entry | The process of using software tools to describe the design requirements of a PLD. Design entry can be done by entering a schematic or a text file that describes the required digital function.
Field Programmable Gate Array (FPGA) | Class of PLDs that contain an array of more complex logic cells that can be very flexibly interconnected to implement high-level logic circuits.
Fitting | Assigning internal PLD circuitry, and input and output pins, to a PLD design.
Integrated Circuit (IC) | An electronic circuit having many components, such as transistors, diodes, resistors, and capacitors, in a single package.
JTAG Port | A four-wire interface specified by the Joint Test Action Group (JTAG) used for loading test data or programming data into a PLD installed in a circuit.
JEDEC | Joint Electron Device Engineering Council.
JEDEC File | An industry standard form of text file indicating which fuses are blown and which are intact in a programmable logic device.
JTAG | Joint Test Action Group. A standards body that developed the format for testing and programming devices while they are installed in a system.
Programmable Logic Device (PLD) | Digital integrated circuit that can be programmed by the user to implement any digital logic function.
Programming | Transferring design information from the computer running PLD design software to the actual PLD chip.
Schematic Entry | A technique of entering CPLD design information by using a CAD (computer aided design) tool to draw a logic circuit as a schematic. The schematic can then be interpreted by design software to generate programming information for the CPLD.
Simple PLD (SPLD) | A PLD with a few hundred logic gates and possibly a few programmable macrocells available.
Target Device | The specific PLD for which a digital design is intended.
TCK | Test Clock. The JTAG signal that drives the JTAG downloading process from one state to the next.
TDI | Test Data In. In a JTAG port, the serial input data to a device.
TDO | Test Data Out. In a JTAG port, the serial output data from a device.
TMS | Test Mode Select. The JTAG signal that controls the downloading of test or programming data.

Instructional Resources

Presentations

Comb Logic Design Process (v3)

Copier Jam Detector

Word Documents

Lesson 2.5 Key Term Crossword

Activity 2.5.1 Programming Tutorial

Project 2.5.2 Date of Birth with PLD

Problem 2.5.3FT Copier Jam Detector

Problem 2.5.3V Copy Jam Detector

Reference Sources

Dueck, R., & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Unit 2 - Sequential Logic

Unit 3 – Sequential Logic

Concepts

1. The flip-flop and transparent latch are logic devices that have the capability to store data and can act as a memory device.

2. Flip-flops and transparent latches have both synchronous and asynchronous inputs.

3. Flip-flops can be used to design single event detection circuits, data synchronizers, shift registers, and frequency dividers.

4. Asynchronous counters, also called ripple counters, are characterized by an external signal clocking the first flip-flop. All subsequent flip-flips are clocked by the output of the previous flip-flop.

5. Asynchronous counters can be implemented using small scale integrated (SSI) and medium scale integrated (MSI) logic gates.

6. Asynchronous counters can be implemented with either D or J/K flip-flops.

7. Up counters, down counters, and modulus counters all can be implemented using the asynchronous counter method.

8. Synchronous counters, also called parallel counters, are characterized by an external signal clocking all flip-flops simultaneously.

9. Synchronous counters can be implemented using small scale integrated (SSI) and medium scale integrated (MSI) logic gates.

10. Synchronous counters can be implemented with either D or J/K flip-flops.

11. Up counters, down counters, and modulus counters all can be implemented using the synchronous counter method.

12. A state machine is a circuit design that sequences through a set of predetermined states controlled by a clock and other input signals.

13. State machines are used to control common everyday devices such as elevator doors, traffic lights, and combinational (electronics) locks.

14. State machines can be implemented in one of two variations: Mealy or Moore.

15. State machines can be implemented using small and medium scale integrated gates and programmable logic devices.

Essential Questions

Lesson 3.1: Latches & Flip-Flops

1. What is the basic function of a flip-flop and transparent latch?

2. What functions do the synchronous and asynchronous inputs serve on flip-flops and transparent latches? Provide an example of each.

3. What are some of the typical applications of flip-flops? Describe how each of these applications work.

Lesson 3.2: Asynchronous Counter

1. Asynchronous counters, also called ripple counters, are characterized by an external signal clocking the first flip-flop. All subsequent flip-flips are clocked by the output of the previous flip-flop.

2. Asynchronous counters can be implemented using small scale integrated (SSI) and medium scale integrated (MSI) logic gates.

3. Asynchronous counters can be implemented with either D or J/K flip-flops.

4. Up counters, down counters, and modulus counters all can be implemented using the asynchronous counter method.

Lesson 3.3: Synchronous Counters

1. What is another name for synchronous counters?

2. How are the clock inputs of a synchronous counter’s flip-flops connected?

3. What is the process for designing synchronous counters implemented using discrete D and J/K flip-flops and medium scale integrated (MSI) circuit counters?

4. What are the differences between a synchronous counter and a synchronous modulus counter?

5. What is the process for designing up, down, and modulus synchronous counters?

Lesson 3.4: Introduction to State-Machine Design

1. What is the basic function of a state machine?

2. What are some common everyday devices that are controlled by state machines?

3. What are the two variations of state machine design, and what are the advantages of each.

4. What type of logic gates are used to implement state machines?

Unit Evaluation

The Essential Questions and Conclusion questions at the end of each activity may be used along with the Assessment suggestions provided in each lesson to develop summative assessment tools, such as tests or end of unit projects.


Lesson 3.1 Flip-Flops and Latches

Concepts

1. The flip-flop and transparent latch are logic devices that have the capability to store data and can act as a memory device.

2. Flip-flops and transparent latches have both synchronous and asynchronous inputs.

3. Flip-flops can be used to design single event detection circuits, data synchronizers, shift registers, and frequency dividers.

Performance Objectives

It is expected that students will:

· Know the schematic symbols and excitation tables for the D and J/K flip-flops.

· Describe the function of the D and J/K flip-flops.

· Describe the function of, and differences between, level sensitive and edge sensitive triggers.

· Describe the function of, and differences between, active high and active low signals.

· Describe the function of, and differences between, a flip-flop’s synchronous and asynchronous inputs.

· Draw detailed timing diagrams for the D or J/K flip-flop’s Q output in response to a variety of synchronous and asynchronous input conditions.

· Analyze and design introductory flip-flop applications such as event detection circuits, data synchronizers, shift registers, and frequency dividers.

· Use Circuit Design Software (CDS) and a Digital Logic Board (DLB) to simulate and prototype introductory flip-flop applications.

Essential Questions

1. What is the basic function of a flip-flop and transparent latch?

2. What functions do the synchronous and asynchronous inputs serve on flip-flops and transparent latches? Provide an example of each.

3. What are some of the typical applications of flip-flops? Describe how each of these applications work.

Key Terms

Asynchronous Counter | Type of counter in which each flip-flop output serves as the clock input signal for the next flip-flop in the chain.
Asynchronous Inputs | Flip-flop inputs that can affect the operation of the flip-flop independent of the synchronous and clock inputs.
Clock | Digital signal in the form of a rectangular pulse train or a square wave.
Clocked D Flip-Flop | Type of flip-flop in which the D (data) input is the synchronous input.
Clocked J-K Flip-Flop | Type of flip-flop in which inputs J and K are the synchronous inputs.
D Latch | Circuit that contains a NAND gate latch and two steering NAND gates.
Duty Cycle (DC) | Fraction of the total period that a digital waveform is in the HIGH state. DC = th/T (often expressed as a percentage: %DC = th/Tx100%).
Edge-Sensitive | Manner in which a flip-flop is activated by a signal transition. A flip-flop may be either a positive- or a negative-edge-triggered flip-flop.
Falling Edge | The part of a pulse where the logic level is in transition from a HIGH to a LOW.
Flip-Flop | A sequential circuit based on a latch whose output changes when its CLOCK input receives a pulse.
Frequency | The number of cycles per unit time of a periodic waveform.
Level-Sensitive | Enabled by a logic HIGH or LOW level.
Period | The amount of time required for one complete cycle of a periodic event or waveform.
PRESET | Asynchronous input used to set Q=1 immediately.
Propagation Delays (tPLH/tPHL) | Delay from the time a signal is applied to the time when the output makes its change.
RESET / CLEAR | Asynchronous input used to set Q=0 immediately.
Rising Edge | The part of a pulse where the logic level is in transition from a LOW to a HIGH.
Sequential Logic | Digital circuitry in which the output state of the circuit depends not only on the states of the inputs, but also on the sequence in which they reached their present states.
Shift Register | Digital circuit that accepts binary data from some input source and then shifts these data through a chain of flip-flops one bit at a time.
State Machines | A sequential circuit that advances through several defined states.
Synchronous Counter | Counter in which all of the flip-flops are clocked simultaneously.
Trigger | Input signal to a flip-flop or one-shot that causes the output to change states depending on the conditions of the control signals.

Instructional Resources

Presentations

Introduction to Flip-Flops and Latches

Flip-Flop Applications

Word Documents

Lesson 3.1 Key Term Crossword

Activity 3.1.1 Introduction to Flip-Flops

Activity 3.1.2 Flip-Flop Application

Reference Sources

Dueck, R., & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 3.2 Asynchronous Counters

Concepts

1. Asynchronous counters, also called ripple counters, are characterized by an external signal clocking the first flip-flop. All subsequent flip-flips are clocked by the output of the previous flip-flop.

2. Asynchronous counters can be implemented using small scale integrated (SSI) and medium scale integrated (MSI) logic gates.

3. Asynchronous counters can be implemented with either D or J/K flip-flops.

4. Up counters, down counters, and modulus counters all can be implemented using the asynchronous counter method.

Performance Objectives

It is expected that students will:

· Know the advantages and disadvantage of counters designed using the asynchronous counter method.

· Be able to describe the ripple effect of an asynchronous counter.

· Be able to analyze and design up, down and modulus asynchronous counters using discrete D and J/K flip-flops.

· Be able to analyze and design up, down and modulus asynchronous counters using medium scale integrated (MSI) circuit counters.

· Use Circuit Design Software (CDS) and Digital Logic Board (DLB) to simulate and prototype SSI and MSI asynchronous counters.

Essential Questions

1. What is another name for an Asynchronous counters?

2. How are the clock inputs of an asynchronous counter’s flip-flops connected?

3. What is the process for designing asynchronous counters implemented using discrete D and J/K flip-flops and medium scale integrated (MSI) circuit counters?

4. What are the differences between an asynchronous counter and an asynchronous modulus counter?

5. What is the process for designing up, down and modulus asynchronous counters?

Key Terms

Asynchronous Counter | Type of counter in which each flip-flop output serves as the clock input signal for the next flip-flop in the chain.
Binary Counter | Group of flip-flops connected in a special arrangement in which the states of the flip-flops represent the binary number equivalent to the number of pulses that have occurred at the input of the counter.
Decade Counter | Any counter capable of going through 10 different logic states.
Down Counter | Counter that counts from a maximum count downward to 0.
Modulus | The number of states through which a counter sequences before repeating.
Modulus N Counter (mod-n counter) | A counter with a modulus of N.
Synchronous Counter | Counter in which all of the flip-flops are clocked simultaneously.
Up Counter | Counter that counts upward from 0 to a maximum count.
Up/Down Counter | Counter that can count up or down depending on how its inputs are activated.

Instructional Resources

Presentations

Asynchronous Counters w/SSI Logic

Asynchronous Counters w/MSI Logic

7-segment Display Driver

Word Documents

Lesson 3.2 Key Term Crossword

Activity 3.2.1 SSI Asynchronous Counters

Activity 3.2.2 SSI Asynchronous Modulus Counters

Activity 3.2.3 PLD Asynchronous Counter Design

Activity 3.2.4 MSI Asynchronous Counters

Optional : Problem 3.2.4 Sixty Second Timer

Reference Sources

Dueck, R. & Reid, K. (2008). Introduction to digital electronics. Clifton Park , NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

Bignell, J., & Donovan, R. (2007). Digital electronics. Clifton Park, NY: Thompson Delmar Learning.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 3.3 Synchronous Counters

Concepts

1. Synchronous counters, also called parallel counters, are characterized by an external signal clocking all flip-flops simultaneously.

2. Synchronous counters can be implemented using small scale integrated (SSI) and medium scale integrated (MSI) logic gates.

3. Synchronous counters can be implemented with either D or J/K flip-flops.

4. Up counters, down counters, and modulus counters all can be implemented using the synchronous counter method.

Performance Objectives

It is expected that students will:

· Know the advantages and disadvantage of counters designed using the synchronous counter method.

· Be able to analyze and design up, down and modulus synchronous counters using discrete D and J/K flip-flops.

· Be able to analyze and design up, down and modulus synchronous counters using medium scale integrated (MSI) circuit counters.

· Use Circuit Design Software (CDS) and Digital Logic Board (DLB) to simulate and prototype SSI and MSI synchronous counters.

Essential Questions

1. What is another name for synchronous counters?

2. How are the clock inputs of a synchronous counter’s flip-flops connected?

3. What is the process for designing synchronous counters implemented using discrete D and J/K flip-flops and medium scale integrated (MSI) circuit counters?

4. What are the differences between a synchronous counter and a synchronous modulus counter?

5. What is the process for designing up, down, and modulus synchronous counters?

Key Terms

Asynchronous Counter | Type of counter in which each flip-flop output serves as the clock input signal for the next flip-flop in the chain.
Binary Counter | Group of flip-flops connected in a special arrangement in which the states of the flip-flops represent the binary number equivalent to the number of pulses that have occurred at the input of the counter.
Decade Counter | Any counter capable of going through 10 different logic states.
Down Counter | Counter that counts from a maximum count downward to 0.
Modulus | The number of states through which a counter sequences before repeating.
Modulus N Counter (mod-n counter) | A counter with a modulus of N.
Synchronous Counter | Counter in which all of the flip-flops are clocked simultaneously.
Up Counter | Counter that counts upward from 0 to a maximum count.
Up/Down Counter | Counter that can count up or down depending on how its inputs are activated.

Instructional Resources

Presentations

Synchronous Counters w/SSI Logic

Synchronous Counters w/MSI Logic

Word Documents

Activity 3.3.1 SSI Synchronous Counters

Activity 3.3.2 MSI ’163 Synchronous Counter

Activity 3.3.3 MSI ‘193 Synchronous Counter

Problem 3.3.4 Now Serving Display Design Project

Reference Sources

Dueck, R. & Reid, K. (2008). Introduction to digital electronics. Clifton Park , NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

Bignell, J., & Donovan, R. (2007). Digital electronics. Clifton Park, NY: Thompson Delmar Learning.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Lesson 3.4 State Machine Design

Concepts

1. A state machine is a circuit design that sequences through a set of predetermined states controlled by a clock and other input signals.

2. State machines are used to control common everyday devices such as elevator doors, traffic lights, and combinational (electronics) locks.

3. State machines can be implemented in one of two variations: Mealy or Moore.

4. State machines can be implemented using small and medium scale integrated gates and programmable logic devices.

Performance Objectives

It is expected that students will:

· Be able to describe the components of a state machine.

· Be able to draw a state graph and construct a state transition table for a state machine.

· Be able to derive a state machine’s Boolean equations from its state transition table.

· Be able to implement Boolean equations into a functional state machine.

· Describe the two variations of state machines and list the advantages of each.

· Use Circuit Design Software (CDS) and a Digital Logic Board (DLB) to simulate and prototype state machines designs implemented with discrete and programmable logic.

Essential Questions

1. What is the basic function of a state machine

2. What are some common everyday devices that are controlled by state machines?

3. What are the two variations of state machine design, and what are the advantages of each.

4. What type of logic gates are used to implement state machines?

Key Terms

Bubble | A circle in a state diagram containing the state name and values of the state variables.
Conditional Transition | A transition between states of a state machine that occurs only under specific conditions of one or more control inputs.
Control Input | A state machine input that directs the operation of the machine from state to state.
Mealy Machine | A state machine whose output is determined by both the sequential logic and the combinational logic of the machine.
Moore Machine | A state machine whose output is determined only by the sequential logic of the machine.
State Machines | A synchronous sequential circuit, consisting of a sequential logic section and a combinational logic section, whose outputs and internal flip-flops progress through a predictable sequence of states in responds to a clock and other input signals.
State Table | A table whose entries represent the sequence of individual FF states (i.e., 0 or 1) for a sequential binary circuit.
State Transition Diagram | A graphic representation of the operation of a sequential binary circuit, showing the sequence of individual FF states and conditions needed for transitions from one state to the next.
State Variables | The variables held in the flip-flops of a state machine that determine its present state.

Instructional Resources

Presentations

State Machine Design

Word Documents

Lesson 3.4 Key Term Crossword

Activity 3.4.1 Introduction to State Machines

Problem 3.4.2FT State Machine

Problem 3.4.2V State Machine

Reference Sources

Dueck,R. &Reid,K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.


Unit 4 - Microcontrollers

Concepts

1. Basic programming skills include variable declaration, loops, and debugging.

2. Programming languages have their own grammar, called syntax.

3. Many everyday products use microcontrollers.

4. Variables used in programming are declared and given a size that is expressed in binary.

5. Microcontrollers are used to control many everyday products like robots, garage door openers, traffic lights, and home thermostats.

6. A servo motor is one that delivers continuous motion at various speeds.

7. Microcontrollers can be programmed to sense and respond to outside stimuli.

8. Digital devices are only relevant if they can interact with the real world.

9. Flowcharting is a powerful graphical organizer used by engineers and professionals in a variety of roles and responsibilities.

10. Realistic problem solving with a control system requires the ability to interface analog inputs and outputs with a digital device.

11. Microcontrollers are a practical tool for controlling a mechanical system.

Essential Questions

Lesson 4.1: Introduction to Microcontrollers

1. What is a microcontroller?

2. What is BASIC?

3. What are the different types of loops and how are they used?

4. What is the purpose of declaring variables?

5. How are variables used in programming?

6. What is syntax and why is it important to know?

Lesson 4.2: Microcontrollers and the Boe-Bot

1. What is a servo motor and what parameters does it use in programming code?

2. What is a tactile switch and how is it used to create an autonomous robot?

Lesson 4.3: Boe-Bot Design Projects

1. How does a microcontroller enable users to interface the analog world with the digital world?

2. How does the design course relate to real-world problems?

Unit Evaluation

The Essential Questions and Conclusion questions at the end of each activity may be used along with the Assessment suggestions provided in each lesson to develop summative assessment tools, such as tests or end of unit projects.


Lesson 4.1 Introduction to Microcontrollers

Concepts

1. Basic programming skills include variable declaration, loops, and debugging.

2. Programming languages have their own grammar, called syntax.

3. Many everyday products use microcontrollers.

4. Variables used in programming are declared and given a size that is expressed in binary.

Performance Objectives

It is expected that students will:

· Use the Board of Education to write programs

· Create a program that utilizes the Debug screen

· Create programs that use variables

· Create programs that use various loops

· Create programs that use inputs and outputs

Essential Questions

1. What is a microcontroller?

2. What is BASIC?

3. What are the different types of loops and how are they used?

4. What is the purpose of declaring variables?

5. How are variables used in programming?

6. What is syntax and why is it important to know?

Key Terms

BASIC | Beginners' All-purpose Symbolic Instruction Code.
BIN | Modifier in PBASIC that designates a variable as being a binary bit.
Bit | Smallest number in binary. Can only have the value of 0 or 1.
Byte | 8 bits. Can have values in range from 0 to 255.
CLS | A command in PBASIC that clears the Debug screen.
Code | A set of computer instructions to perform a given operation or solve a given problem.
Comment | A line of text in a computer program that is ignored by the computer. Comments are used to explain programs to humans.
CR | A command in PBASIC that moves the Debug screen down one line or to end the SEROUT command. Also called a carriage return.
Debug | The process of detecting and eliminating a device’s malfunctions.
DEBUG | A command in PBASIC that sends text and values to the screen.
DEC | A modifier in PBASIC that designates a variable as being a decimal number.
Declare | The process of informing a program that you plan to use a variable, what you want to call it, and how big it is.
DO Loop | A command in PBASIC that tells a series of commands to loop endlessly.
ESD | Electrostatic discharge. An electronic current that can damage components.
Flowchart | A schematic representation of an algorithm or a process.
FOR…NEXT | A command in PBASIC that is a type of loop that depends on a variable to act as a counter. A series of commands will run until the counter number is reached.
HEX | A modifier in PBASIC that designates a variable as being a hexadecimal number.
Microcontroller | A microcomputer used for precise process control in data handling, communication, or manufacturing.
Nibble | 4 bits. Can have values from 0 to 15.
PAUSE | A command in PBASIC that tells a computer to continue the last command for a given number of milliseconds.
SEROUT | A command in PBASIC that is used to transmit asynchronous serial data; an example is that of a servo motor.
Syntax | The rules governing the structure of statements used in a program.
Word | 16 bits. Can have values from 0 to 65,535.

Instructional Resources

Presentations

Introduction to Microcontrollers and the Board-of-Education (BOE)

Board-of-Education Output

Board-of-Education Input

Word Documents

Lesson 4.1 Key Term Crossword

Activity 4.1.1 Microcontrollers and the BOE

Activity 4.1.2 Microcontroller Output

Activity 4.1.3 Microcontroller Input

Parallax PDF Documents

Activity 4.1.1

Activity 4.1.2

Activity 4.1.3

Reference Sources

Dueck,R. &Reid,K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Floyd, Thomas (2006). Digital Fundamentals. Upper Saddle River, NY Pearson Education

International Technology Education Association (ITEA). (2002). Standards for technological literacy.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for English language arts.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.


Lesson 4.2 Microcontrollers and the Boe-Bot

Lesson 4.2 Microcontrollers & The Boe-Bot

Concepts

1. Microcontrollers are used to control many everyday products like robots, garage door openers, traffic lights, and home thermostats.

2. A servo motor is one that delivers continuous motion at various speeds.

3. Microcontrollers can be programmed to sense and respond to outside stimuli.

Performance Objectives

It is expected that students will:

· Program a servo motor.

· Program and test an autonomous robot.

· Use mathematics to calculate programming values.

Essential Questions

1. What is a servo motor and what parameters does it use in programming code?

2. What is a tactile switch and how is it used to create an autonomous robot?

Key Terms

Servo Motor | A motor that delivers continuous motion at various speeds.
PULSOUT | A command in PBASIC that generates a pulse on Pin with a width of Duration.
Tactile Switch | A device that changes state based on touch input to its sensors.
Horn | Shaft on the servo motor controlled by PBASIC.
Duration | Modifier on the PULSOUT command in PBASIC; determines the number of 2-ms time spans for the length of the high signal.

Instructional Resources

Presentations

The Bot-Bot and Servo Motors

Boe-Bot Navigation

Boe-Bot Tactile Whiskers

Word Documents

Lesson 4.2 Key Term Crossword

Activity 4.2.1 Assemble and Test the Boe-Bot

Activity 4.2.2 Boe-Bot Navigation

Activity 4.2.3 Boe-Bot Tactile Whiskers

Parallax PDF Documents

Activity 4.2.1

Activity 4.2.2

Activity 4.2.3

Reference Sources

Dueck, R., & Reid, K. (2008). Introduction to digital electronics. Clifton Park, NY: Thompson Delmar Learning.

Floyd, T. (2006). Digital fundamentals. Upper Saddle River, NY: Pearson Education.

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.

Parallax Inc. (2004). What’s a microcontroller. Retrieved June 20, 2008, from http://www.parallax.com/tabid/440/Default.aspx

Parallax Inc. (2004). Robotics with the Boe-Bot. Retrieved June 24, 2008, from http://www.parallax.com/tabid/440/Default.aspx


Lesson 4.3 Boe-Bot Design Projects

Concepts

1. Digital devices are only relevant if they can interact with the real world.

2. Flowcharting is a powerful graphical organizer used by engineers and professionals in a variety of roles and responsibilities.

3. Realistic problem solving with a control system requires the ability to interface analog inputs and outputs with a digital device.

4. Microcontrollers are a practical tool for controlling a mechanical system.

Performance Objectives

It is expected that students will:

· Draw a flowchart for a microcontroller program that will be used to maneuver a robot.

· Program a microcontroller to maneuver a robot through a design course.

Essential Questions

1. How does a microcontroller enable users to interface the analog world with the digital world?

2. How does the design course relate to real-world problems?

Key Terms

Analog | Having a continuous set of values.
Control | A device or mechanism used to regulate or guide the operation of a machine, apparatus, or system.
Digital | Having a series of individual values (discrete).
Discrete | Individual values.
Interface | The place at which independent and often unrelated systems meet and act on or communicate with each other.
Mechanical | Produced or operated by a machine or tool.
Microcontroller | A computer on a chip.

Instructional Resources

Word Documents

Lesson 4.3 Key Term Crossword

Project 4.3.1 Boe-Bot Design Projects

Parallax PDF Documents

Activity 4.3.1A

Activity 4.3.1B

Activity 4.3.1C

Reference Sources

International Technology Education Association, (2000). Standards for technological literacy. Reston, VA: ITEA.

National Council of Teachers of English (NCTE) and International Reading Association (IRA) (1996). Standards for the English language arts. Newark, DE: IRA; Urbana, IL: NCTE.

National Council of Teachers of Mathematics (NCTM). (2000). Principles and standards for school mathematics. Reston, VA: Author.

National Research Council (NRC). (1996). National science education standards. Washington, D. C.: National Academy Press.

Tocci, R., Widmer, N., & Moss, G. (2007). Digital systems: Principles and applications. Upper Saddle River, NJ: Pearson Education.

Tokeim, R. L. (2003). Digital electronics principles and applications. Columbus, OH: Glencoe/McGraw-Hill.


It is illegal to make copies of this course without the permission of

Project Lead The Way, Inc.

All software, courseware, images and material contained in this course are the property of Project Lead The Way, Inc., unless otherwise provided, and are protected under federal copyright law. It is illegal to make and/or distribute any of the contents of this course without the permission of Project Lead The Way, Inc. The use of this course and its contents is for the PLTW Program, by its network of educational institutions, schools, teachers and affiliates, in accordance with the terms of their agreements with Project Lead The Way, Inc. Duplication or other use of this file without proper authorization may be against federal law, and may subject you to monetary and other penalties.

Please Report Copyright Violations To:

Project Lead The Way, Inc.

3939 Priority Way South Drive Suite 200

Indianapolis, IN 46240

Copyright 2009-2012 Project Lead The Way, Inc.


Introduction to DE Course

Introduction – Digital Electronics Course

This file is intended to be a complete teaching curriculum, not just a guide or an outline. The curriculum is composed of units, which contain lessons and activities. The teacher guidelines and resource materials are integrated, via links, into the curriculum to make it easier for teachers to have access to the teaching tools needed to implement the course.

Each Unit begins with a Purpose, a listing of Concepts, Essential Questions, and Lessons for the Unit with a recommendation for Unit Evaluations. The Concepts are the broad learning objectives for the unit. The intent of the Essential Questions, in combination with the Purpose of each lesson that is an anticipatory set, is to create a framework for teachers and students to focus student learning. Course specific projects can be developed by the students to solve problems posed by the questions. The Concepts and Essential Questions along with the anticipatory set should be communicated to the students at the beginning of every Unit to establish the focus of the unit’s learning objectives.

Each Unit is composed of lessons. Included in the Lessons are the Concepts specific to each Lesson; a listing of technology, science, mathematics, and English language arts national standards; Performance Objectives aligned with the national standards; Assessment suggestions; Essential questions aligned with the Concepts; Key Terms; a Day-by-Day Lesson plan; and a listing of instructional resources to aid instruction. Each of these components is clearly discussed and described in the Lesson Template and Activities, Projects, Problems Template found in the Course Implementation Suggestions section. Each Lesson is to begin with the instructor presenting the Lesson’s Purpose and Essential Questions to the students for them to think about and to develop solutions to, by the end of the Lesson. These questions are repeated for students at the end of an activity that is designed to help students focus their thoughts, learn skills, and apply those skills to solve problems, a key tenet of project-based learning.

This curriculum is designed to be taught to high school students within a typical high school schedule. This means that a class which meets each day for 40-45 minutes, 175 days a year should be able to cover the content of this course. Some minor adjustments will need to be made by those schools that teach under a double block system. For the most part, this will simply entail combining two days worth of activities into one.


Key Terms Glossary

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

1’s Complement | A form of signed binary notation in which negative numbers are created by complementing all bits of a number, including the sign bit.
2’s Complement | A form of signed binary notation in which negative numbers are created by adding 1 to the 1’s complement form of the number.
555 Timer | TTL-compatible IC that can be wired to operate in several different modes, such as a one-shot and an astable multivibrator.
Back to Top A
Adjacent Cell | Two cells in a K-map are adjacent if there is only one variable that is different between the coordinates of the two cells.
Amplitude | The instantaneous voltage of a waveform. Often used to mean maximum amplitude, or peak voltage, or a pulse.
Analog | A way of representing some physical quantity, such as temperature or velocity, by a proportional continuous voltage or current. An analog voltage or current can have any value within a defined range.
AND Gate | Digital circuit that implements the AND operation. The output of this circuit is HIGH only if all of its inputs are HIGH.
Associative Property | A mathematical function is associative if its operands can be grouped in any order without affecting the result. For example, addition is associative ((a+b) + c = a + (b+c)), but subtraction is not ((a-b) –c ≠ a-(b-c)).
Asynchronous Counter | Type of counter in which each flip-flop output serves as the clock input signal for the next flip-flop in the chain.
Asynchronous Inputs | Flip-flop inputs that can affect the operation of the flip-flop independent of the synchronous and clock inputs.
Atom | The smallest particle of an element that still has the same characteristics as the element.
Back to Top B
BASIC | Beginners' All-purpose Symbolic Instruction Code.
BIN | Modifier in PBASIC that designates a variable as being a binary bit.
Binary Counter | Group of flip-flops connected in a special arrangement in which the states of the flip-flops represent the binary number equivalent to the number of pulses that have occurred at the input of the counter.
Binary Number System | A number system used extensively in digital systems, based on the number 2. It uses two digits to write any number.
Bit | Smallest number in binary. Can only have the value of 0 or 1.
Boolean Algebra | Algebraic process used as a tool in the design and analysis of digital systems. In Boolean algebra only two values are possible, 0 and 1.
Boolean Expression | An algebraic expression made up of Boolean variables and operators, such as AND (-), OR (+), or NOT (-). Also referred to as Boolean function or a logic function.
Boolean Theorems | Rules that can be applied to Boolean algebra to simplify logic expressions.
Boolean Variable | A variable having only two possible values, such as HIGH/LOW, 1/0, On/Off, or True/False.
Breadboard | A circuit board for wiring temporary circuits, usually used for prototypes or laboratory work.
Bubble | A circle in a state diagram containing the state name and values of the state variables.
Byte | 8 bits. Can have values in range from 0 to 255.
Back to Top C
Capacitor | An electrical device used to store electrical charge.
Cell | The smallest unit of Karnaugh map, corresponding to one line of a truth table. The input variables are the cell’s coordinates and the output variable is the cell’s contents.
Clock | Digital signal in the form of a rectangular pulse train or a square wave.
Clocked D Flip-Flop |  | Type of flip-flop in which the D (data) input is the synchronous input.
Clocked J-K Flip-Flop | Type of flip-flop in which inputs J and K are the synchronous inputs.
CLS |  | A command in PBASIC that clears the Debug screen.
Code |  | A set of computer instructions to perform a given operation or solve a given problem.
Cold Solder Joint |  | A solder connection that exhibits poor wetting and is characterized by a grayish, porous appearance due to excessive impurities in the solder, inadequate cleaning prior to soldering, and/or the insufficient application of heat during the soldering process.
Combinational Logic |  | Digital circuitry in which an output is derived from the combination of inputs, independent of the order in which they are applied.
Comment |  | A line of text in a computer program that is ignored by the computer. Comments are used to explain programs to humans.
Common Anode Display |  | A seven-segment LED display where the anodes of all the LEDs are connected to the circuit supply voltage. Each segment is illuminated by a logic LOW at its cathode.
Common Cathode Display |  | A seven-segment display in which the cathodes of all the LEDs are connected together and grounded. A logic HIGH illuminates a segment when applied to its anode.
Commutative Property |  | A mathematical operation is commutative if it can be applied to its operands in any order without affecting the result. For example, addition is commutative (a+b=b+a), but subtraction is not (a-b≠b-a).
Compiler |  | The process used by CPLD design software to interpret design information (such as a schematic or text file) and create required programming information for a CPLD.
Complex PLD (CPLD) |  | A digital device consisting of several programmable sections with internal interconnections between the sections.
Conditional Transition |  | A transition between states of a state machine that occurs only under specific conditions of one or more control inputs.
Conductor |  | Any material that allows the free movement of electric changes, such as electrons, to provide an electric current.
Control |  | A device or mechanism used to regulate or guide the operation of a machine, apparatus, or system.
Control Input |  | A state machine input that directs the operation of the machine from state to state.
Conventional Current |  | The direction of current flow associated with positive charge in motion. The current flow direction is from a positive to negative potential, which is in the opposite direction of electron flow.
CR |  | A command in PBASIC that moves the Debug screen down one line or to end the SEROUT command. Also called a carriage return.
Current |  | A movement of electrical charges around a closed path or circuit.
Back to Top D
D Latch | Circuit that contains a NAND gate latch and two steering NAND gates.
Datasheet | A printed specification giving details of the pin configuration, electrical properties, and mechanical profile of an electronic device.
Debug | The process of detecting and eliminating a device’s malfunctions.
DEBUG | A command in PBASIC that sends text and values to the screen.
DEC | A modifier in PBASIC that designates a variable as being a decimal number.
Decade Counter | Any counter capable of going through 10 different logic states.
Decimal System | Number system that uses 10 different digits or symbols to represent a quantity.
Declare | The process of informing a program that you plan to use a variable, what you want to call it, and how big it is.
DeMorgan’s Theorems | Theorem stating that the complement of a sum (OR operation) equals the product (AND operation) of the complements, and theorem stating that the complement of a product (AND operation) equals the sum (OR operation) of the complements.
De-multiplexer | A circuit that uses a binary decoder to direct a digital signal from a single source to one of several destinations.
Design Entry | The process of using software tools to describe the design requirements of a PLD. Design entry can be done by entering a schematic or a text file that describes the required digital function.
Design Specifications | A detailed description, especially one providing information needed to make, build, or produce something.
Digital | A way of representing a physical quantity by a series of binary numbers. A digital representation can have only specific discrete values.
Digital Multimeter | Electronic test equipment that can perform multiple tasks. Typically one capable of measuring voltage, current, and resistance. More sophisticated modern digital multimeters also measure capacitance, inductance, current gain of transistors, and/or anything else that can be measured electronically.
Digital Waveform | A series of logic 1s and 0s plotted as a function of time.
Diode | A two terminal device that conducts in only one direction.
Discrete | Individual values.
Distributive Property | Full name: distributive property of multiplication over addition. The property that allows us to distribute (“multiply through”) an AND across several OR functions. For example, a(b+c)=ab+ac.
DO Loop | A command in PBASIC that tells a series of commands to loop endlessly.
Don’t Care Condition | Situation when a circuit’s output level for a given set of input conditions can be assigned as either a 1 or 0.
Down Counter | Counter that counts from a maximum count downward to 0.
Dual In-Line Package (DIP) | A very common IC package with two parallel rows of pins intended to be inserted into a socket of through holes drilled in a printed circuit board.
Duration | Modifier on the PULSOUT command in PBASIC; determines the number of 2-ms time spans for the length of the high signal.
Duty Cycle (DC) | Fraction of the total period that a digital waveform is in the HIGH state. DC = th/T (often expressed as a percentage: %DC = th/Tx100%).
Back to Top E
Edge-Sensitive | Manner in which a flip-flop is activated by a signal transition. A flip-flop may be either a positive- or a negative-edge-triggered flip-flop.
Electron | Basic particle of negative charge in orbit; around the nucleus in an atom.
Electron Flow | Current of negative charges in motion. Direction is from the negative terminal of the voltage source, through the external, circuit, and returning to the positive side of the source. Opposite to the direction of conventional current.
Encoder | A digital circuit that produces an output code depending on which of its inputs is activated.
Engineering Notation | A floating point system in which numbers are expressed as products consisting of a number greater than one multiplied by an appropriate power of ten that is some multiple of three.
ESD | Electrostatic discharge. An electronic current that can damage components.
Exclusive-NOR (XNOR) Circuit | Two-input logic circuit that produces a high output only when the inputs are equal.
Exclusive-OR (XOR) Circuit | Two-input logic circuit that produces a high output only when the inputs are different.
Back to Top F
Falling Edge | The part of a pulse where the logic level is in transition from a HIGH to a LOW.
Field Programmable Gate Array (FPGA) | Class of PLDs that contain an array of more complex logic cells that can be very flexibly interconnected to implement high-level logic circuits.
Fitting | Assigning internal PLD circuitry, and input and output pins, to a PLD design.
Flip-Flop | A sequential circuit based on a latch whose output changes when its CLOCK input receives a pulse.
Flowchart | A schematic representation of an algorithm or a process.
FOR…NEXT | A command in PBASIC that is a type of loop that depends on a variable to act as a counter. A series of commands will run until the counter number is reached.
Frequency | The number of cycles per unit time of a periodic waveform.
Full Adder | Logic circuit with three inputs and two outputs. The inputs are a carry bit (CIN) from a previous stage, a bit from the augend, and a bit from the addend, respectively. The outputs are the sum bit and the carry-out bit (COUT) produced by the addition of the bit from the addend with the bit from the augend and CIN.
Fuse | A protective device in the current path that melts or breaks when current exceeds a predetermined maximum value.
Back to Top G
Back to Top H
Half Adder | Logic circuit with two inputs and two outputs. The inputs are a bit from the augend and a bit from the addend. The outputs are the sum bit produced by the addition of the bit from the addend with the bit from the augend and the resulting carry (COUT) bit, which will be added to the next stage.
Hertz (Hz) | Unit of frequency. One hertz equals one cycle per second.
HEX | A modifier in PBASIC that designates a variable as being a hexadecimal number.
Hexadecimal Number System | Base-16 number system. Hexadecimal numbers are written with sixteen digits, 0-9 and A-F, with power-of-16 positional multipliers.
Horn | Shaft on the servo motor controlled by PBASIC.
Back to Top I
Insulator | A material that does not allow current to flow when voltage is applied because of its high resistance.
Integrated Circuit (IC) | An electronic circuit having many components, such as transistors, diodes, resistors, and capacitors, in a single package.
Interface | The place at which independent and often unrelated systems meet and act on or communicate with each other.
Inverter | Also called a NOT gate or an inverting buffer. A logic gate that changes its input logic level to the opposite state.
Back to Top J
JEDEC | Joint Electron Device Engineering Council.
JEDEC File | An industry standard form of text file indicating which fuses are blown and which are intact in a programmable logic device.
JTAG | Joint Test Action Group. A standards body that developed the format for testing and programming devices while they are installed in a system.
JTAG Port | A four-wire interface specified by the Joint Test Action Group (JTAG) used for loading test data or programming data into a PLD installed in a circuit.
Back to Top K
Karnaugh Map |  |  | A graphical tool for finding the maximum SOP or POS simplification of a Boolean expression. A Karnaugh map works by arranging the terms of an expression so that variable scans are cancelled by grouping minterms or maxterms.
Kirchhoff’s Current Law (KCL) |  |  | The algebraic sum of all currents into and out of any branch point in a circuit must equal zero.
Kirchhoff’s Voltage Law (KVL) |  |  | The algebraic sum of all voltages around any closed path must equal zero.
Back to Top L
Large Scale Integration (LSI) |  |  | An IC that contains circuitry equivalent to 100 gates or more.
Least Significant Bit (LSB) |  |  | The rightmost bit of a binary num ber. This bit has the number’s smallest positional multiplier.
LED |  |  | Light-emitting diode. An electronic device that conducts current in one direction only and illuminates when it is conducting.
Level-Sensitive |  |  | Enabled by a logic HIGH or LOW level.
Logic Circuit |  |  | Any circuit that behaves according to a set of logic rules.
Logic Diagram |  |  | A diagram, similar to a schematic, showing the connection of logic gates.
Logic Gate |  |  | An electronic circuit that performs a Boolean algebraic function.
Logic HIGH |  |  | The higher of two voltages in a digital system with two logic levels.
Logic LOW |  |  | The lower of two voltages in a digital system with two logic levels.
Back to Top M
Maxterm |  |  | A sum term in a Boolean expression where all possible variables appear once in true or complement form.
Mealy Machine |  |  | A state machine whose output is determined by both the sequential logic and the combinational logic of the machine.
Mechanical |  |  | Produced or operated by a machine or tool.
Medium Scale Integration (MSI) |  |  | An IC that contains circuitry equivalent to more than 11 and less than 100 gates.
Microcontroller |  |  | A microcomputer used for precise process control in data handling, communication, or manufacturing.
Minterm |  |  | A product term in a Boolean expression where all possible variables appear once in true or complement form.
Modulus |  |  | The number of states through which a counter sequences before repeating.
Modulus N Counter (mod-n counter) |  |  | A counter with a modulus of N.
Moore Machine |  |  | A state machine whose output is determined only by the sequential logic of the machine.
Most Significant Bit (MSB) |  |  | The leftmost bit in a binary number. This bit has the number’s loargest positional multiplier.
Multiplexer |  |  | A circuit that directs one of several digital signals to a single output, depending on the states of several select inputs.
Back to Top N
NAND Gate |  |  | Logic circuit that operates like an AND gate followed by an INVERTER. The output of a NAND gate is LOW (logic level 0) only if all inputs are HIGH (logic level 1).
Nibble |  |  | 4 bits. Can have values from 0 to 15.
NOR Gate |  |  | Logic circuit that operates like an OR gate followed by an INVERTER. The output of a NOR gate is LOW (logic level 0) when any or all inputs are HIGH (logic level 1).
NOT Circuit |  |  | Also called an INVERTER gate or an inverting buffer. A logic gate that changes its input logic level to the opposite state.
Nucleus |  |  | The massive, stable part of the atom that contains both protons and neutrons.
Back to Top O
Octal Number System |  |  | A number system that has a base of 8; digits from 0 to 7 are used to express an octal number.
Ohm’s Law |  |  | In electric circuits, I=V/R.
Ohms |  |  | Unit of resistance. Value of one ohm allow current of one ampere with potential difference of one volt.
OR Gate |  |  | Digital circuit that implements the OR operation. The output of this circuit is HIGH (logic level 1) if any or all of its inputs are HIGH.
Oscilloscope |  |  | A piece of test equipment used to view and measure a variety of different waveforms.
Back to Top P
Parallel Circuit |  |  | One that has two or more branches for separate current from one voltage source.
PAUSE |  |  | A command in PBASIC that tells a computer to continue the last command for a given number of milliseconds.
Period |  |  | The amount of time required for one complete cycle of a periodic event or waveform.
Plastic Leaded Chip Carrier (PLCC) |  |  | A square IC package with leads on all four sides designed for surface mounting on a circuit board.
PRESET |  |  | Asynchronous input used to set Q=1 immediately.
Printed Circuit Board |  |  | Insulating board containing conductive tracks for circuit connections.
Product Term |  |  | A term in a Boolean expression where one or more true or complement variables are ANDed.
Product-of-Sums (POS) |  |  | A type of Boolean expression where several sum terms are multiplied (ANDed) together.
Programmable Logic Device (PLD) |  |  | Digital integrated circuit that can be programmed by the user to implement any digital logic function.
Programming |  |  | Transferring design information from the computer running PLD design software to the actual PLD chip.
Propagation Delays (tPLH/tPHL) |  |  | Delay from the time a signal is applied to the time when the output makes its change.
Proton |  |  | Particle with positive charge in the nucleus of an atom.
PULSOUT |  |  | A command in PBASIC that generates a pulse on Pin with a width of Duration.
Back to Top Q
Back to Top R
RESET / CLEAR |  |  | Asynchronous input used to set Q=0 immediately.
Resistance |  |  | Opposition to current. Unit is the ohm.
Resistor |  |  | Component made of material that opposes flow of current and therefore has some value of resistance.
Resistor Color Code |  |  | Coding system of colored stripes on a resistor to indicate the resistor's value and tolerance.
Rising Edge |  |  | The part of a pulse where the logic level is in transition from a LOW to a HIGH.
Back to Top S
Schematic Entry |  |  | A technique of entering CPLD design information by using a CAD (computer aided design) tool to draw a logic circuit as a schematic. The schematic can then be interpreted by design software to generate programming information for the CPLD.
Schottky TTL |  |  | TTL subfamily that uses the basic TTL standard circuit except that it uses a Schottky barrier code (SBD) connected between the base and the collector of each transistor for faster switching.
Scientific Notation |  |  | Numbers entered as a number from one to ten multiplied by a power of ten.
Sequential Logic |  |  | Digital circuitry in which the output state of the circuit depends not only on the states of the inputs, but also on the sequence in which they reached their present states.
SEROUT |  |  | A command in PBASIC that is used to transmit asynchronous serial data; an example is that of a servo motor.
Series Circuit |  |  | One that has only one path current.
Servo Motor |  |  | A motor that delivers continuous motion at various speeds.
Seven-Segment Display |  |  | An array of seven independently controlled light-emitting diodes (LED) or liquid crystal display (LCD) elements, shaped like a figure-8, which can be used to display decimal digits and other characters by turning on the appropriate elements.
Shift Register |  |  | Digital circuit that accepts binary data from some input source and then shifts these data through a chain of flip-flops one bit at a time.
SI Notation |  |  | Abbreviation of System International, a system of practical units based on the meter, kilogram, second, ampere, Kelvin, mole, and candela.
Sign Bit |  |  |  | A binary bit that is added to the leftmost position of a binary number to indicate whether that number represents a positive or a negative quantity.
Signed Binary Number |  |  |  | A binary number of fixed length whose sign is represented by one bit, usually the most significant bit, and whose magnitude is represented by the remaining bits.
Simple PLD (SPLD) |  |  |  | A PLD with a few hundred logic gates and possibly a few programmable macrocells available.
Simulation |  |  |  | Testing design function by specifying a set of inputs and observing the resultant outputs. Simulation is generally shown as a series of input and output waveforms.
Sine Wave |  |  |  | One in which amplitude varies in proportion to the sine function of an angle.
Small Outline IC (SOIC) |  |  |  | An IC package similar to a DIP, but smaller, which is designed for automatic placement and soldering on the surface of a circuit board.
Small Outline Integrated Circuit (SOIC) |  |  |  | Dual-inline style surface-mount IC package.
Small-Scale Integration (SSI) |  |  |  | An integrated circuit having 12 or fewer gates in one package.
Solder |  |  |  | Metallic alloy of tin and lead that is used to join two metal surfaces.
Solder Bridge |  |  |  | The unwanted formation of a conductive path of solder between conductors.
Soldering |  |  |  | Process of joining two metallic surfaces to make an electrical contact by melting solder (usually tin and lead) across them.
Soldering Iron |  |  |  | Tool with an internal heating element used to heat surfaces being soldered to the point where the solder becomes molten.
Square Wave |  |  |  | An almost instantaneous rise and decay of voltage or current in a periodic pattern with time and with a constant peak value.
State Machines |  |  |  | A synchronous sequential circuit, consisting of a sequential logic section and a combinational logic section, whose outputs and internal flip-flops progress through a predictable sequence of states in responds to a clock and other input signals.
State Table |  |  |  | A table whose entries represent the sequence of individual FF states (i.e., 0 or 1) for a sequential binary circuit.
State Transition Diagram |  |  |  | A graphic representation of the operation of a sequential binary circuit, showing the sequence of individual FF states and conditions needed for transitions from one state to the next.
State Variables |  |  |  | The variables held in the flip-flops of a state machine that determine its present state.
Sum Term |  |  |  | A term in a Boolean expression where one or more true or complement variables are ORed.
Sum-of-Products (SOP) |  |  |  | A type of Boolean expression where several product terms are summed (ORed) together.
Synchronous Counter |  |  |  | Counter in which all of the flip-flops are clocked simultaneously.
Syntax |  | The rules governing the structure of statements used in a program.
Back to Top T
Tactile Switch | A device that changes state based on touch input to its sensors.
Target Device | The specific PLD for which a digital design is intended.
TCK | Test Clock. The JTAG signal that drives the JTAG downloading process from one state to the next.
TDI | Test Data In. In a JTAG port, the serial input data to a device.
TDO | Test Data Out. In a JTAG port, the serial output data from a device.
Tinning | The process of applying a thin coat of solder to materials prior to their being soldered; for example, application of a light coat of solder to the filaments of a conductor to hold the filaments in place prior to soldering the conductor.
TMS | Test Mode Select. The JTAG signal that controls the downloading of test or programming data.
Transistor | Term derived from "transfer resistor." Semiconductor device that can be used as an amplifier or as an electronic switch.
Transistor-Transistor (TTL) | A family of digital logic devices whose basic element is the bipolar junction transistor.
Trigger | Input signal to a flip-flop or one-shot that causes the output to change states depending on the conditions of the control signals.
Truth Table | A list of all possible input values to a digital circuit, listed in ascending binary order, and the output response for each input combination.
Back to Top U
Up Counter | Counter that counts upward from 0 to a maximum count.
Up/Down Counter | Counter that can count up or down depending on how its inputs are activated.
Back to Top V
Back to Top W
Word | 16 bits. Can have values from 0 to 65,535.
Back to Top X
Back to Top Y
Back to Top Z Back to Top


General PLTW Document

Citations in APA Style

Introduction

The following style of citation is based on the sixth edition of Publication Manual of the American Psychological Association (APA). It is recommended that this document be purchased and used as a reference in the classroom or laboratory.

Additional online resources include the following:

Purdue University Online Writing Lab (OWL)

American Psychological Association (APA) Basics of APA Style® Tutorial

American Psychological Association (APA) APA Style Blog

Cornell University Library Citation Management

Journal article, one author, doi available

Format

Author, A. A. (year). Title of article. Title of Periodical, xx, pp-pp. doi:xx.xxxxxxxxxx

Example

Shyndale, G.W. (2010). Virtual truss design. Journal of Software Engineering, 14, 84-87. doi: 14.3291/0632-7640.42.4.756

Notes

The digital object identifier (doi) is a document identification number that can be found on most (but not all) digital journal articles. If the doi is listed with the reference information, include it in your citation as indicated below.

Journal article, one author, doi not available

Format

Author, A. A. (year). Title of article. Title of Periodical, xx, pp-pp. Retrieved from http://www.xxxxxxxxxx

Example

Shyndale, G.W. (2010). Virtual truss design. Journal of Software Engineering, 14, 84-87. Retrieved from http://www.jrnsoftwareeng/trussdesign

Notes

If the doi is not listed with the reference information, indicate the URL of the home page from which you retrieved the journal article.

Magazine article

Format

Author, A. A. (year, month). Title of article. Title of Magazine, xx(x), pp-pp. Retrieved from http://www.xxxxxxxxxx

Example

Williamson, H. K. (2011, January). Discrete transistor circuit design. Tomorrow’s Electronics, 24(1), 15-22. Retrieved from www.tomorrowselectronics.com/discretetransistor

Notes

Provide the date shown on the publication. Provide the month for monthlies or month and day for weeklies.

The xx(x) in the format sample below represents volume and issue number. Please provide volume and issue number in your reference.

If the magazine article is retrieved from a hard copy magazine, no URL is necessary. If the magazine article is retrieved online, please include the appropriate URL.

Daily newspaper article, no author

Format

Title of article. (year, month day). Title of Newspaper, pp.

OR

Title of article. (year, month day). Title of Newspaper. Retrieved from http://www.xxxxxxxxxx

Example

Stem cell differentiation. (2012, March 14). The Gazette, C8.

OR

Stem cell differentiation. (2012, March 14). The Gazette. Retrieved from http://www.gazettedaily.com

Notes

If the newspaper article is retrieved from a hard copy newspaper, include the page number. If the newspaper article is retrieved online, please include the newspaper’s homepage URL.

Daily newspaper article with author

Format

Author, A. A. (year, month day). Title of article. Title of Newspaper, pp.

OR

Author, A. A. (year, month day). Title of article. Title of Newspaper. Retrieved from http://www.xxxxxxxxxx

Example

Burkowski, D. O. (2009, January 14). Environmental impact of bioethanol. Savannah Times, A14.

OR

Burkowski, D. O. (2009, January 14). Environmental impact of bioethanol. Savannah Times. Retrieved from http://www.SavannahTimes.org

Book with author or editor

Format

Author, A. A. (date). Title of book. doi:xx.xxxxxxxxxx

OR

Author, A. A. (date). Title of book. Retrieved from http://www.xxxxxxxxxx

OR

Author, A. A. (date). Title of book. Publication location: Publisher.

OR

Editor, A. A., Editor, B. B., & Editor, C. C. (date). Title of book. Publication location: Publisher.

Example

Grantham, T. G. (2006). Fluid mechanics. doi:10.6024/8473629821.001.0001

OR

Grantham, T. G. (2006). Fluid mechanics. Retrieved from http://www.intechopen.com/books/FluidMechanics

OR

Grantham, T. G. (2006). Fluid mechanics. Pittsburgh, PA: Mechanical Advantage, Inc.

OR

Smith, A. K., Trudeau, C. D., & Filan, J. T. (2008). In pursuit of cures. Hartford, CT: Biolabs, Inc.

Notes

If the book is retrieved online and provides a doi, include the doi in the reference.

If the book is retrieved online but does not provide a doi, include the URL of the retrieval site.

If the book is retrieved as a hard copy, include the publication information.

If the book is edited rather than authored, please reference all authors.

Documentaries or motion pictures

Format

Producer, A. A. (Producer), & Director, B. B. (Director). (Year). Title of recording. [Documentary]. Country of Origin: Studio.

Example

Jarrett, G. A. (Producer), & Schultz, B. Q. (Director). (2012). What makes us move? Innovation in biomechanics. [Documentary]. Canada: Educast, Inc.

Notes

Identify the nature of the recording in brackets after the title.

Software

Format

Title of Software. (Version number) [Computer software]. Publication location: Publisher.

Example

CircuitDesign. (4.0) [Computer software]. Seattle, WA: Oakdeck, Inc.


DE Equations and Theorems

Digital Electronics Equations, Theorems, and Laws

Ohm’s Law:

<or> [image] <or>

Units: I (amperes, A); R (resistance, Ω); V (voltage, V)

Kirchoff’s Current Law:

The total current in a parallel circuit equals the sum of the individual branch currents.

<or>

Kirchoff’s Voltage Law:

The sum of all of the voltage drops in a series circuit equals the total applied voltage.

<or>

555 Timer Design Equations:

Period:

Frequency:

Duty Cycle:


Example Design Process

Project Lead The Way, Inc. has adopted this design process from Standards for Technological Literacy Standard 8, Benchmark H. This design process will be used for all courses. The design process includes:

1. Define a Problem

· Identify a problem that exists.

· Determine the root cause.

· Gather information.

2. Brainstorm

· Present ideas in group.

· Generate and record ideas.

· Seek quantity, not quality.

· Keep the mind alert through rapidly paced sessions.

3. Research and Generate Ideas

· Analyze the reasons for the need, want, or problem.

· Investigate who or what is affected, and consider the need, want, or problem from their perspective.

· Research any existing solutions, and identify why they are not adequate or appropriate.

· Listen to clients to solve problems that they have discovered.

· Perform market research to determine if a want or need exists and warrants the development of a design solution.

4. Identify Criteria and Specify Constraints

· Identify the end user if it is different than the client.

· Redefine the problem to the agreement of both client and engineer.

· Identify what the solution must do, and the degree to which it will be pursued.

· Identify the limitations within which the engineer must perform his/her duties.

· Compile the information into a design brief.

5. Explore Possibilities

· Initiate further development of brainstorming ideas with constraints and tradeoffs considered.

· Explore alternative ideas based on further knowledge and technologies.

6. Select an Approach

· Create a decision-matrix to compare the attributes of the various ideas and analyze the trade-offs associated with each one.

· Verify alignment between the idea selected and the criteria and constraints.

7. Develop a Design Proposal

· Develop detailed and annotated sketches.

· Determine the type(s) of material from which the solution will be constructed.

· Make computer models.

· Create technical drawings from the computer model(s).

8. Make a Model or Prototype

· Make study models (scaled models or mock-ups).

· Fabricate a functional prototype.

9. Test and Evaluate the Design using Specifications

· Test the prototype under controlled conditions.

· Test the prototype under actual conditions.

· Record the results.

· Evaluate results to determine if problems exist and further work is needed.

10. Refine the Design

· Reassess the validity of the design criteria and make adjustments to the design brief, if necessary.

· Work through the design process until the solution satisfies the design criteria.

· Update the documentation of the final solution.

11. Create or Make Solution

· Determine custom/mass production.

· Consider packaging.

12. Communicate Processes and Results

· Present oral presentations with visual aids (computer-generated slide show, models, prototype).

· Develop written reports with appropriate graphic documentation (charts, graphs, technical drawings, renderings, etc.).

· Market the Product.

· Distribute.


Presentation Rationale

An effective presentation of a design proposal is a critical step in the design process. It must clearly state the main points and precise details to enable a product to evolve from an idea to the market place. The presentation culminates with evaluation and feedback from a review panel.

All presentation components should reflect preparation, anticipation, and organization and be delivered with accuracy, brevity, and clarity.

Presentation Components

The Written Report should:

· Describe the design and the design process thoroughly.

· Document with technical accuracy the facts, data, results, and references used and collected.

· Use a standardized format for composing research papers following established written language mechanics.

· Be presented prior to the oral presentation.

The Oral Presentation should:

· Communicate all necessary project details in a clear, concise manner.

· Demonstrate confidence and enthusiasm to command the attention of the audience.

· Conclude with a strong summary that restates important points and reinforces what the audience has learned.

Visual Aids should be:

· Relevant and should clearly convey the desired information.

· Accurate 3D representation in the form of a mockup, prototype, or 3D solid model to enhance and support the presentation.

The Review of Presentation and Report should include an:

· Opportunity to present before an audience including a panel of experts, the class, members of advisory committee, parents, teachers, administration, and members of the media.

· Audiences that will serve to review, validate, and provide feedback to address the technical accuracy and relevancy of the presentation.

· Assessment of the written reports, oral presentation, and visual aids using rubrics provided in the curriculum.


Sample Engineer's Notebook Entries

Sample Engineer’s Notebook Entries

The following would be considered excellent examples of entries in an engineer’s notebook.

Why do the previous examples represent outstanding entries in an engineer’s notebook?

· The pages have been sequentially numbered.

· The pages are part of a bound notebook.

· There is a dedicated location on each page for the designer’s and witness’s dated signatures.

· All figures and calculations have been clearly labeled.

· Inserted items have been properly attached to their respective pages.

· The date for each entry is clearly identified.

· The student included annotated sketches that help the reader understand the ideas.

· Detailed explanations of how the designs are supposed to work were given.

· The student gave evidence of research.

· Problems that were encountered through experimentation were chronicled, and ideas to fix them were clearly evident.

· A technical drawing for a prototype was given, which specified the material from which the part was to be made.

· A digital photograph of the prototype was included that suggests how the object is to be assembled.

· The information given in the entries is proportional to the amount of time given per class period.

· Any mistakes that were made had a single line drawn through them. Mistakes were initialed.

The following is an example of an unacceptable engineer’s notebook. Keep in mind that each entry represents a reflection of 75 minutes of continuous work.

Why does the previous example represent an unacceptable engineer’s notebook?

· The student submitted a sheet of loose leaf paper that was removed from a wire bound spiral notebook. An engineer’s notebook must be a bound document. No pages should ever be removed from an engineer’s notebook.

· The page number is not identified in ink.

· The student did not sign and date the page.

· Several class meetings between 9/22 and 10/11 are not represented by notebook entries.

· No sketches, CAD model graphics, or technical drawings are included to support the idea that the support bar, guide, or displacement arm was actually designed or being built. It also appeared that the student was leaving room so that he/she could go back and add sketches later on in an attempt to satisfy the rubric.

· Except for wood, which encompasses a broad spectrum, no tools or materials were identified as being used.

· The student offered no explanation as to functions of the support bar, wood guide, and displacement arm.

· The entries do not show that the partners talked about their ideas or worked on their designs as a team.

· The entries do not talk about any special considerations or problems that might have been encountered during the design of the parts.

· Only fragments of ideas have been documented. There is no detail at all.

· The student used inappropriate expletives in a formal document and was openly disrespectful to his/her teammate.

· 75 minutes of work cannot be accurately and completely summed up in one sentence.


Written Report Format

Reports need to be neat, organized, and word-processed. When reports are completed, someone should be able to read them and duplicate the results. Reports should be written in the third person with no pronouns. These reports should include the following components.

TITLE PAGE

In a list format, the title page should include:

· Title of project

· Names of student participants

· Course title

· Institution where work was done

· Date

ABSTRACT

Summarize in a paragraph the objectives of the project and what was accomplished. Include specific information to support your point. This one-paragraph summary should be short and to the point with specific information.

TABLE OF CONTENTS

Include all sections of your report, listed in order with the corresponding page numbers needed to find the information. This may be a page or more in length.

INTRODUCTION

Include answers to the following questions in this brief explanation of the project or activities:

· What is the purpose of the activity?

· What are you going to learn and what are you going to do?

BACKGROUND

Include the information and background research of the topic. Inform the reader about the information you gathered in order to accomplish the task. Describe what you found and studied of previous research and designs done by others. Explain why your work is different.

MATERIALS

Bulleted list of all materials needed to do the project or activity.

PROCEDURE

Present the details on how you did the lab, activity or project. Include your specific step-by-step process such as, sketches, schematics, equations, and photos. Specify what was learned at each step. This section may be broken into subsections.

RESULTS

Discuss how well the objectives were accomplished. Include suggestions for improvement and the kinds of errors and problems that occurred during the process. Write a short paragraph projecting where this project could go in the future. Compare your results with your initial stated purpose.

CONCLUSION

Give a brief summary of what you learned and what the activity was all about.

APPENDIX

Include the following:

· Drawings

o  Orthographic

o  Isometric

o  Assembly

o  Exploded views

· Schematics

· Written programs

· Flow charts

· Tables of information

· Pertinent information to the report but too large to fit in the written documentation

CITATIONS

Include all resources, such as books, magazines, journals, and Internet sources that were used to obtain and learn information. Since this is a technical report, the format should follow APA guidelines.